Firefox hangs with 100% CPU when using gmail's chat pop-out feature

RESOLVED INVALID

Status

()

Firefox
General
--
critical
RESOLVED INVALID
10 years ago
10 years ago

People

(Reporter: RK, Unassigned)

Tracking

({hang})

2.0 Branch
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.12) Gecko/20080207 Ubuntu/7.10 (gutsy) Firefox/2.0.0.12
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.12) Gecko/20080207 Ubuntu/7.10 (gutsy) Firefox/2.0.0.12

NOTE: YOU NEED A GMAIL ACCOUNT TO REPRODUCE THIS PROBLEM

Recently, Google rolled out a new feature to enable bloggers to chat with their site visitors through the web (gtalk is not required).

You can login with you gmail account then get the Ifame for here: http://www.google.com/talk/service/badge/New

Sense, I'm using Linux, I have to use the web-embedded chat in my Gmail account.  This is where Firefox crash. It crashed when I was testing that feature by chatting with my self. All you have to do is click Pop-out on the chat. Follow steps exactly!


Reproducible: Always

Steps to Reproduce:
1.Login with you gmail account
2.go to http://www.google.com/talk/service/badge/New
3.Copy the Ifram html source and save it to a file on you desktop (test.html)
4.Go to you gmail account an sign in to your embedded chat
5-Open test.html (Your online status should be green) and click on your account name. This should open a new window for the chat.
6.Go back in your gmail inbox, a little html chat window should be in to bottom right corner or the browser. Click Pop-out.
Actual Results:  
Firefox tries to open a new window for the chat then it the browsers hangs for ever with 100% CPU utilization. 

Expected Results:  
The same chat window that was opened from test.html, should contain open a new "HTML" tab for the other chat (the one opened from gmail inbox by clicking pop-out)


I think it's something with JavaScript and AJAX because I've seen the same issue on other sites, where the browser just hangs with 100 CPU. This time its finally consistent enough to report...
Did firefox crash or hang? These are two different things.

Is the problem reproducible if you make a new firefox profile for a test?
- http://kb.mozillazine.org/Profile_manager
(Do not delete your existing profile)
Version: unspecified → 2.0 Branch
(Reporter)

Comment 2

10 years ago
Created attachment 306039 [details]
BeforeBrowserHangs

This attachment shows the prefinal step to reproduce this bug.

RK
(Reporter)

Comment 3

10 years ago
The bowser hangs, it doesn't crash.

I tried it with a new test profile and the problem stopped happening...
If this hang doesn't exist with a new profile then it's probably a problem due to an extension, theme or setting. Most probably an extension - so try disabling them one-by-one until you find the culprit.
Keywords: hang
(Reporter)

Comment 5

10 years ago
Its Google toolbar!!!
Disable it and the problem goes away, enable it and here we be again...

Thanks for your help.
--> INVALID (problem due to 3rd party extension)
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.