Save contents of search field too if session saving is activated

RESOLVED WONTFIX

Status

Camino Graveyard
General
RESOLVED WONTFIX
11 years ago
9 years ago

People

(Reporter: Markus Amalthea Magnuson, Unassigned)

Tracking

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; sv; rv:1.8.1.13pre) Gecko/20080213 Camino/1.6b3pre (like Firefox/2.0.0.13pre)
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; sv; rv:1.8.1.13pre) Gecko/20080213 Camino/1.6b3pre (like Firefox/2.0.0.13pre)

When the option "Load the pages that were open before quitting" is enabled, the contents of the search field should be saved too.

Reproducible: Always

Steps to Reproduce:
1. Enable the option "Load the pages that were open before quitting"
2. Open some tabs and write something in the search field
3. Restart Camino
Actual Results:  
Tabs are restored but the search field is empty

Expected Results:  
The contents of the search field should be restored too

Comment 1

10 years ago
I'm in favour of this.

See also bug 408078. FWIW, Safari only does the latter and does not appear to save the contents of search fields.

Comment 2

9 years ago
I think of the search field as transient, rather than browser state, so I'd lean toward WONTFIX, but I don't feel strongly either way. Other opinions? We should make a call one way or the other.
I think Chris said Firefox does this, but I also tend to think of search strings  as extremely transient; I'm not sure why I'd want to quit with stuff in the search field and have it preserved and not also have my search results page still open to be preserved and be useful next launch.

Also, if we implement bug 408078, implementing this bug becomes more difficult, since we'll have >1 strings to store.  All in all, I'm leaning WONTFIX, also.

Comment 4

9 years ago
Firefox may not have made a conscious choice to do it; they just serialize the whole window. So that counts even less than usual ;)

Comment 5

9 years ago
We've got three WF votes without me, and I've changed my mind anyway, so that makes four. Sorry, Markus.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.