If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Installer cannot open mozmapi32.dll

RESOLVED DUPLICATE of bug 404609

Status

Thunderbird
Installer
--
major
RESOLVED DUPLICATE of bug 404609
10 years ago
10 years ago

People

(Reporter: Chris, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.12) Gecko/20080201 Firefox/2.0.0.12
Build Identifier: Thunderbird 2.0.0.12

My older version of Thunderbird attempted an automatic update yet could not update all files.  After multiple attempts, I uninstalled and began installing build 2.0.0.12 from scratch.  I received the following message:  "Error opening file for writing", that file being mozmapi32.dll.  To make matter worse, i am unable to delete the Thunderbird files already written to my hard drive by the faulty installation.  If I try, I get the message that mozmapi32.dll cannot be deleted.  If I attempt to reinstall on top of the remaining files, I once more get that this file cannot be opened for writing.  I have unchecked "read only" but this has not helped. Help!

Reproducible: Always

Steps to Reproduce:
1.
2.
3.
(Reporter)

Updated

10 years ago
Severity: normal → major
Judging by the duplicates of the update bug (bug 340535) and of the various installer bugs, 90% chance that it's quickcam, the software for a logitech webcam, that has mozmapi32.dll locked, and shutting that down will let you install/update. If not, someone in any of the support channels in http://www.mozilla.org/support/thunderbird/forums should be able to help you track it down, or sneak around it by installing in a different directory.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 404609

Comment 2

10 years ago
I had this problem, and it was the web cam. Shutting the web cam down, solved the problem.
You need to log in before you can comment on or make changes to this bug.