Closed Bug 420021 Opened 15 years ago Closed 15 years ago

Download Manager disappears within moments of clicking "All files have finished downloading"

Categories

(Toolkit :: Downloads API, defect)

x86
All
defect
Not set
normal

Tracking

()

VERIFIED DUPLICATE of bug 397935

People

(Reporter: musikgoat, Unassigned)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b3) Gecko/2008020514 Firefox/3.0b3
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b3) Gecko/2008020514 Firefox/3.0b3

When using the option to save files to a specific directory, after the Download Manager completes the virus check and disappears, once the "All files have finished downloading" pop-up shows,  if you click on that pop up, the Download Manager only momentarily shows, then disappears.  During the time that the pop-up is displayed, you can actually click multiple times, and each time, only momentarily, the Download Manager displays.  I first saw the error on GranParidiso build in the Ubuntu Gutsy repository,  and have replicated it on two XP machines.   
An interesting note is that this does not happen when right-clicking and saving the file to a specific directory. 

Reproducible: Always

Steps to Reproduce:
1. Ensure that Options -> General -> Downloads -> Save files to ... is set and being used.
2. Find any downloadable item, I used the FF3b4pre exe as an example, http://forums.mozillazine.org/viewtopic.php?p=3263575#3263575
3. Click on the item and choose to save the file
4. Wait for the Download Manager to complete the download, scan for viruses, and close.
5. When the "All files have finished downloading" pop-up shows, click on it.
Actual Results:  
The Download Manager shows up momentarily and then crashes or disappears from view on the desktop.

Expected Results:  
The Download Manager should display, allowing access to recently downloaded items.

I am going to see if this is reproducable with a default profile, as in both instances, I used profiles imported from FF2.
Assuming you have the "auto close" pref set, this is a dupe of bug 397935.
Status: UNCONFIRMED → RESOLVED
Closed: 15 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 397935
Verified dup; pretty sure that's it, too.  Do reopen if it's not.
Status: RESOLVED → VERIFIED
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.