No "remember password" checkbox in proxy login/password popup

RESOLVED INVALID

Status

()

Toolkit
Password Manager
--
enhancement
RESOLVED INVALID
11 years ago
10 years ago

People

(Reporter: Laurent G., Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b3) Gecko/2008020514 Firefox/3.0b3
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b3) Gecko/2008020514 Firefox/3.0b3

(Firefox/3.0b3) When using a Proxy (using "Automatic proxy configuration" settings), the login/password popup appears at launch, but there is no checkbox to remember the settings. You must provide both login/password at each start of the browser...

Reproducible: Always

Steps to Reproduce:
1.start Firefox 3.0b3 (with Proxy enabled)

Actual Results:  
Empty login/password popup appears

Expected Results:  
The Login/password popup should remember the last values (if you check a corresponding checkbox of course).
Do you not get a notification bar on the page being loaded?
(Reporter)

Comment 2

11 years ago
I did not understand what you meant by "notification bar". So I restarted Firefox with a new profile (profile manager option). Now I understand: there IS indeed a line under the address bar asking if I want to remember the password for the site... 

After a lot of tests with different empty profiles, I know why I didn't see it before: I browse with a lot of disabled things. Especially Javascript, and I don't use the "remember password" option (Tools=>Options=>Security=>Remember passwords for site). When I installed Firefox, I disabled this option BEFORE I changed the proxy settings and connected to internet. And when you disable this option, the message in the "notification bar" does not appear! So I never had the opportunity to see it, of course.

I've reenabled the option, saved the password, now it works OK.

However: I think that the use of this "notification bar" is non obvious, and I don't understand why the proxy is handled in the same way as the web sites. After all, that's not really the same thing... I mean, from an user point of view, the Proxy is not a web site, and when you get the message asking to remember the password when you start on Google for instance, it does not make sense. (even if I understand technically that this is in fact the same thing)

For me, the "Remember passwords for site" option should only work for forms in web sites and authentication popup for sites (BASIC authentication, etc.)
In my opinion this is confusing. Even when I saw the message in the notification bar, I would not have understood it was about the Proxy password if I had not read your remark...

Conclusion:
=> would it be possible to change the Message displayed when the "site" address is the Proxy's?
=> would it also be possible not to disable the message (for Proxy) when the "Remember passwords for site" is disabled in the options?

Thanks.
(In reply to comment #2)
> Now I understand: there IS
> indeed a line under the address bar asking if I want to remember the password
> for the site... 

Ok, then nothing is broken. :-)

> However: I think that the use of this "notification bar" is non obvious, and I
> don't understand why the proxy is handled in the same way as the web sites.

This was changed to a notification bar because with the old way, you didn't have any way to know if the login you were saving was actually going to work.

Proxy logins are handled the same as other logins, because the primary reason for that checkbox is for people who don't want the browser to remember their logins for anything. There's a bug on improving what it says, which I'd like to change in some future release.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → INVALID
(Assignee)

Updated

10 years ago
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.