Error at opening Select Addresses dialog

VERIFIED DUPLICATE of bug 41364

Status

SeaMonkey
MailNews: Address Book & Contacts
P3
major
VERIFIED DUPLICATE of bug 41364
18 years ago
14 years ago

People

(Reporter: Masaki Katakai, Assigned: scottputterman)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
It is easy to reproduce this problem,

1) Open New Mail Compose Window
2) click Address on toolbar

The following errors are displayed on console.
And when I selected "Reply to All" for compose, no address was listed
on the Select Address dialog. The recipients should be listed there.

JavaScript error:
chrome://messenger/content/addressbook/abSelectAddressesDialog.js line 32: missi
ng ) after argument list

JavaScript error:
line 0: OnLoadSelectAddress is not defined

Comment 1

18 years ago
Please specify which build (ie. date) you are using.  Thanks.
QA Contact: lchiang → esther

Comment 2

18 years ago
Confirmed for build 2000060908, but with a different JavaScript error:

chrome://messenger/content/messengercompose/MsgComposeCommands.js line 708:
msgCompose has no properties.

However, I have not attempted to confirm the "Reply to All" problem; just the
problem of clicking on the Adress button on the toolbar.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 3

18 years ago
JavaScript error:

    if (args.preselectid) {

        identity = getIdentityForKey(args.preselectid);
    }
    else
    {
        //WE GET STUCK HERE
        // no preselect, so use the default account
        var identities = accountManager.defaultAccount.identities;
        
    	identity = identities.QueryElementAt(0, 
Components.interfaces.nsIMsgIdentity);
    }

we seem to get stuck assigning a value to identities.  this prevents 
ComposeStartup() from finishing, thus preventing this from happening:

msgCompose = msgComposeService.InitCompose(window, args.originalMsg, args.type, 
args.format, args.fieldsAddr, identity);

Thus, msgCompose remains null, the value it was assigned previously, causing it 
to have no properties, causing a JS error later on in SelectAddress() in this 
line:
var msgCompFields = msgCompose.compFields;

However, I'm not sure why we get stuck on var identities = 
accountManager.defaultAccount.identities; or identity = 
identities.QueryElementAt(0, Components.interfaces.nsIMsgIdentity);

The following appears in the console:
 line 0: uncaught exception: [Exception... "Component returned failure code: 0x8
0004005 (NS_ERROR_FAILURE) [nsIMsgAccountManager.defaultAccount]"  nsresult: "0x
80004005 (NS_ERROR_FAILURE)"  location: "JS frame :: chrome://messenger/content/
messengercompose/MsgComposeCommands.js :: ComposeStartup :: line 187"  data: no]

cc'ing alec, I'll take a look at this tomorrow if he doesn't get a chance

Comment 4

18 years ago
sorry, please excuse my first line: "JavaScript error:"  ... that was part of 
the uncaught exception error that appeared in the console

Updated

18 years ago
Severity: normal → major
(Reporter)

Comment 5

18 years ago
I'm seeing this problem on LINUX 2000060908. The error of
abSelectAddressesDialog.js happens when I just clicked on "Address"
on Compose Window. I don't have any address list on the
address book. I tried just after deleting ~/.mozilla and
setting up my mail box.
(Assignee)

Comment 6

18 years ago
I'm pretty sure this original bug is a dup of 41364.  I have a fix for this.  
The problem is that we were missing a quote in one of our files which causes 
everything to get parsed incorrectly.

*** This bug has been marked as a duplicate of 41364 ***
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE

Comment 7

18 years ago
verified as duplicate, the reply to all list all the addresses too. 
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.