Tasks wont display if 1st day in multiweek view

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
11 years ago
9 years ago

People

(Reporter: itshectic, Unassigned)

Tracking

Sunbird 0.7
x86
Windows Vista

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.8.1.12) Gecko/20080201 Firefox/2.0.0.12
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.8.1.8pre) Gecko/20071023 Sunbird/0.7

Picture shows what happens. See the task on March 3rd which is visible in the 1st picture but mysteriously disappears in the 2nd picture because I highlighted a different day, this only happens if its the 1st day in the multiweek view.

http://img221.imageshack.us/img221/770/bugtu9.jpg

http://img262.imageshack.us/img262/6899/bug2cv4.jpg

Reproducible: Always

Steps to Reproduce:
1. Create task on a day that can possibly display as the 1st in view for "multiweek"
2. check that it exists in normal view (it should)
3. Highlight a day that will have the task appear as the 1st day in multiweek view for example 31st of march for April(if Monday is set as 1st day of the week)
Actual Results:  
The task disappears from the calender view but still exists.

Expected Results:  
It should of displayed the task(s) for that day as it would otherwise.

None.
What is your timezone configured in Sunbird? What is the start time for the task?

I remember a bug about events/tasks not being displayed if the start falls into the range [week start +- UTC-timezone-offset] but I can't find the bug currently.
(Reporter)

Comment 2

11 years ago
Timezone is GMT+10
The start time is 8am
Adam, do you still see the issue using the latest release? 

I can't reproduce it using Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b4pre) Gecko/20090324 Calendar/1.0pre (BuildID: 20090324052046). 

For testing I set my system timezone to GMT+10 and the Sunbird timezone to Australia/Sydney.
Version: unspecified → Sunbird 0.7
I tried differnt settings and also cannot reproduce the behaviour.

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.3a2pre) Gecko/20100220 Lightning/1.1a1pre Shredder/3.2a1pre
wfm per previous comment.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.