on Vista use browsertabbar-toolbox for navigation toolbar

RESOLVED DUPLICATE of bug 420236

Status

()

Firefox
Theme
RESOLVED DUPLICATE of bug 420236
10 years ago
10 years ago

People

(Reporter: beltzner, Unassigned)

Tracking

Trunk
x86
Windows Vista
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [ignore comment 0, see comment 1])

Attachments

(1 attachment)

Created attachment 306449 [details]
mockup of toolbar styling for vista

In winstripe, we currently wrap all toolbars in a single box and style that box as a -moz-appearance: toolbox.

For Vista, we would like:

 - menu bar to be -moz-appearance: toolbox
 - a new box containing the other toolbars styled as -moz-appearance: browsertabbar-toolbox

See attached mockup.
Ugh. Ignore comment 0, please.

In winstripe, we currently wrap all toolbars in a single box and style that box
as a -moz-appearance: toolbox. For Vista, we would like to additionally style the navigation toolbar with -moz-appearance: browsertabbar-toolbox ! important to give it the Vista button toolbar styling.

See attached mockup.

The tabstrip colour changes will be tracked by another bug.
Whiteboard: [ignore comment 0, see comment 1]
Blocks: 420236
No longer blocks: 420236
Blocks: 420232
No longer depends on: 420232
Summary: on Vista use browsertabbar-toolbox around navigation toolbar and all toolbars below it → on Vista use browsertabbar-toolbox for navigation toolbar
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 420236
Merging this bug with the tabstrip one since most of the discussion is going on over there.
You need to log in before you can comment on or make changes to this bug.