Search using awesomebar locationbar doesn't always find history entries

RESOLVED INVALID

Status

()

defect
RESOLVED INVALID
11 years ago
11 years ago

People

(Reporter: naylor83, Unassigned)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b4pre) Gecko/2008022806 Minefield/3.0b4pre
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b4pre) Gecko/2008022806 Minefield/3.0b4pre

When I type in a word into the location bar it doesn't always find the relevant history entries.

For instance, in the past 60 days (my history cutoff) I have visited the website "Helgessons kök", http://www.helgessons.se/. Now when I type "helgessons" (no quotes) into the location bar I get nothing, even though it should match both the URL and the page title.

When I do the same search in the History side-bar I *do* find the website. (Se attached screenshot.)

I have tested this in safe mode. Could this be because of the Swedish chars in the page title? This previously happened to me with another Swedish page, "Leif på hörnet" (http://leifpahornet.se/).

Reproducible: Sometimes

Steps to Reproduce:
1. Visit a page (with non-english chars in title?)
2. Close tab, open a new tab.
3. Type a word from the page title into the location bar.
Actual Results:  
The relevant history entries are not found.

Expected Results:  
The relevant history entries should be found.

Even if this is linked to non-english characters in the title, it doesn't happen all the time. For instance, now I am able to find http://leifpahornet.se/ from the location bar.

Very erratic and very annoying. :)
(Reporter)

Comment 1

11 years ago
(Reporter)

Updated

11 years ago
Summary: Search using awesomebar doesn't always find history entries → Search using awesomebar locationbar doesn't always find history entries
Component: History → Places
QA Contact: history → places
Version: unspecified → Trunk
Component: Places → Location Bar and Autocomplete
QA Contact: places → location.bar

Comment 2

11 years ago
Works for me. I visited www.helgessons.se and type "helg" and I see it. Can you find it after visiting it? Or bookmarking it?
(Reporter)

Comment 3

11 years ago
Yes, it's a nasty one this one since it doesn't occur all the time.

Yes, I have visited the page, and it was probably in the last 14 days, while my history cutoff is 60 days. ("Keep my history for *at least* 60 days.") So if you ask me, it should find it.

In the attached screenshot my cursor was in the URL bar, so the dropdown should have come up and suggested helgessons just like the History search to the left did.

Actually, I should probably either change the description of this bug or submit a new one, because I see now that this doesn't always work for bookmarks either. For instance I bookmarked this very page yesterday, and now if I type in "420271", no quotes, it won't find it. I can reproduce this for several other bookmarks too.
(Reporter)

Comment 4

11 years ago
DOH! Invalid!

I had forgotten I had changed the setting match only typed in about:config... Sorry guys.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.