smarter lock file handling

RESOLVED DUPLICATE of bug 307147

Status

()

Firefox
Shell Integration
RESOLVED DUPLICATE of bug 307147
10 years ago
4 years ago

People

(Reporter: Simon Wunderlin, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.12) Gecko/20080207 Ubuntu/7.10 (gutsy) Firefox/2.0.0.12
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.12) Gecko/20080207 Ubuntu/7.10 (gutsy) Firefox/2.0.0.12

if my desktop crashes (or is crashed by ctrl+alt+backspace) firefox's lockfiles in the profile folder don't get purged. after making sure no firefox is running and logging in again, i get the message that a lock file is still there and that firefox is unable to start.

couldn't the startup shell script check if there is a running instance of ff/xulrunner and if not kill the lock files and start anyway (maybe with the "restore session prompt") ?

Reproducible: Always

Steps to Reproduce:
1. kill firefox on linux
2. make sure there are no ff processes running anymore
3. restart firefox
4. get a message that ff can't start because log file is still there
5. Profit!!1!
Actual Results:  
firefox won't start

Expected Results:  
firefox should start ;)

This situation happens on ubuntu 7.1 and debian 4. no other systems tested due to lack of availability.

the unix novice is probably puzzled how to solve this problem. firefox could do them a great favour.

Comment 1

10 years ago
we can't use the shell script as it's optional, distros don't always choose to ship it.
Whiteboard: DUPEME

Updated

10 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 307147

Updated

4 years ago
Whiteboard: DUPEME
You need to log in before you can comment on or make changes to this bug.