Closed Bug 420325 Opened 13 years ago Closed 13 years ago

Selecting a menu item with the cursor, and moving with the keyboard results in two selected items

Categories

(Core :: Widget: Win32, defect, P2)

x86
Windows XP
defect

Tracking

()

VERIFIED FIXED

People

(Reporter: adelfino, Assigned: vlad)

References

Details

(Keywords: regression)

Attachments

(2 files)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b4pre) Gecko/2008022904 Minefield/3.0b4pre
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b4pre) Gecko/2008022904 Minefield/3.0b4pre

Selecting a menu item with the cursor, and moving with the keyboard while holding <Crtl> + <Shift> results in two selected item.

Reproducible: Always

Steps to Reproduce:
1. Focus a menu item with the cursor.
2. Hold <Ctrl> or <Shift> (keep then pressed).
3. Move with the arrows.
Actual Results:  
The menu has two selected items.

The item that was focused with the cursor, is opened if one clicks it.

The item that was focused with the arrows and <Ctrl>/<Shift> is s opened if one pressed <Enter>

Expected Results:  
Only one item should be selected.
Summary: Selecting a menu item with the cursor, and moving with the keyboard while holding <Crtl> + <Shift> results in two selected item → Selecting a menu item with the cursor, and moving with the keyboard while holding <Crtl> + <Shift> results in two selected items
Attachment #306533 - Attachment description: In this screenshot, the cursor is focusing Find Again. I pressed: <Ctrl> + <Up> → In this screenshot, the cursor is focusing Find Again. I pressed: <Ctrl> + <Up>, and <Up> again.
Actually, you don't have to _hold_ <Ctrl> to duplicate selected items. Just press any key that wouldn't activate something in the menu, nor close it, and then move with arrows.

Examples:

<Ctrl>, then <Up>/<Down>.
<Shift>, then <Up>/<Down>.
E, then <Up>/<Down> (in Edit menu).
Summary: Selecting a menu item with the cursor, and moving with the keyboard while holding <Crtl> + <Shift> results in two selected items → Selecting a menu item with the cursor, and moving with the keyboard after pressing <Crtl>/<Shift>/an unused letter results in two selected items
Note that the only thing you have to do is select an item menu with the cursor, and move with the arrow keys to get duplicated selected items.
Flags: blocking-firefox3?
Summary: Selecting a menu item with the cursor, and moving with the keyboard after pressing <Crtl>/<Shift>/an unused letter results in two selected items → Selecting a menu item with the cursor, and moving with the keyboard results in two selected items
--> Core::Widget:Win32
Status: UNCONFIRMED → NEW
Component: Menus → Widget: Win32
Ever confirmed: true
Flags: blocking-firefox3?
Keywords: regression
Product: Firefox → Core
Nominating for blocking/P2. Vlad, dunno if this is related to the menuItem hover state stuff and/or the same issue that we're seeing cause problems in bug 420237.
Flags: blocking1.9?
Priority: -- → P2
Mm, yeah, this is me.  mozmenuactive vs. hover is being an issue here, I guess we can't trust hover without mozmenuactive.
Assignee: nobody → vladimir
Flags: blocking1.9? → blocking1.9+
I broke this recently (by adding a check for hover), so let's unbreak it.

The reason why I broke it was to try to make -moz-appearance: menuitem work in the awesomebar dropdown, which, for some reason, is not getting the mozmenuactive attribute applied.  That should probably be the actual bug that gets fixed for that.
Attachment #307780 - Flags: review?
Attachment #307780 - Flags: review? → review?(enndeakin)
Comment on attachment 307780 [details] [diff] [review]
let's unbreak this

> The reason why I broke it was to try to make -moz-appearance: menuitem work in
> the awesomebar dropdown, which, for some reason, is not getting the
mozmenuactive attribute applied.

Because the items in the autocomplete are richlistitems.
Attachment #307780 - Flags: review?(enndeakin) → review+
Checked in.
Status: NEW → RESOLVED
Closed: 13 years ago
Resolution: --- → FIXED
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.