Closed Bug 420364 Opened 12 years ago Closed 12 years ago

Update to meeting requests fail with "showError is not defined"

Categories

(Calendar :: Lightning Only, defect, major)

defect
Not set
major

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: bugzilla, Assigned: Fallen)

Details

Attachments

(1 file, 1 obsolete file)

User-Agent:       Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 5.1; Q312461; .NET CLR 1.0.3705; .NET CLR 1.1.4322; InfoPath.1; .NET CLR 2.0.50727)
Build Identifier: 2.0.0.12 (20080213)

When receiving updates to meeting reqeusts sent from Outlook (both Exchange and non-Exchange attached), the update is not processed and the following error is thrown:

Error: uncaught exception: [Exception... "'[JavaScript Error: "showError is not defined" 
{file: "chrome://lightning/content/imip-bar.js" line: 400}]' when calling method: 
[calIOperationListener::onOperationComplete]"  nsresult: "0x80570021 
(NS_ERROR_XPC_JAVASCRIPT_ERROR_WITH_DETAILS)"  location: "JS frame :: 
file:///C:/Documents%20and%20Settings/scott/Application%20Data/Thunderbird/Profiles/jlrkrt7r.default/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/components/calStorageCalendar.js 
:: anonymous :: line 400"  data: yes]

This was tested with meetings sent from Outlook versions "2007 SP1 MS0" and "2003 (11.8118.8132) SP2"

Reproducible: Always

Steps to Reproduce:
1.Third party sends meeting request.
2.Open meeting request and "accept".
3.Third party send update to existing meeting request.
4.Open meeting request and "accept".
5.No action is taken no error is thrown except for the Error Console

Actual Results:  
Meeting is not updated, no error is displayed except in the Error Console

Expected Results:  
The meeting should have been updated and moved to the new time slot.
Product: Thunderbird → Calendar
QA Contact: general → general
Component: General → Lightning Only
OS: Windows XP → All
QA Contact: general → lightning
Hardware: PC → All
This was only with a single calendar.
Attached patch Fix v1 (obsolete) — Splinter Review
Yes I see why this happens. showError is defined in import-export.js, but when messageWindow.xul is overlayed, then this script is never included.
Assignee: nobody → philipp
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Attachment #306768 - Flags: review?
Attachment #306768 - Flags: review? → review?(mschroeder)
Attached patch Fix v2Splinter Review
Better - Move showError into calUtils.js
Attachment #306768 - Attachment is obsolete: true
Attachment #306773 - Flags: review?(mschroeder)
Attachment #306768 - Flags: review?(mschroeder)
Comment on attachment 306773 [details] [diff] [review]
Fix v2

r=mvl
Attachment #306773 - Flags: review?(mschroeder) → review+
Checked in on HEAD and MOZILLA_1_8_BRANCH

-> FIXED
Status: ASSIGNED → RESOLVED
Closed: 12 years ago
Resolution: --- → FIXED
Target Milestone: --- → 0.8
This was my first report of a bug.  Where can I find the process,
or can someone tell me here, what is the life cycle or work flow
as to how this fix is integrated into a release, or a release 
schedule, time lines, etc.  

Thanks

This fix is integrated into current nightlies since 2008-03-02, and also rc1 and the upcoming final 0.8 release.
You need to log in before you can comment on or make changes to this bug.