If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

drag+drop for image works second time

VERIFIED FIXED in mozilla1.4beta

Status

()

Core
Editor
P3
normal
VERIFIED FIXED
18 years ago
15 years ago

People

(Reporter: sujay, Assigned: kinmoz)

Tracking

({helpwanted, topembed+})

Trunk
mozilla1.4beta
helpwanted, topembed+
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [d&d]editorbase+,edt_x3)

Attachments

(1 attachment, 2 obsolete attachments)

(Reporter)

Description

18 years ago
using 6/9 build of netscape

1) launch netscape
2) launch composer
3) insert image
4) drag and drop that image somewhere below the first image.

intially this doesn't work...but when you try it again the second time
it works.

all platforms.

Comment 1

18 years ago
setting to m17
Target Milestone: --- → M17
(Reporter)

Comment 2

18 years ago
okay just talked to Kathy...the issue here is that if you click the image first
and then drag it, it works...but if you select it and then try dragging it
doesn'w work...

I feel either way shoulod work for the user...Beth can you approve having us
fix it so it works both ways?

Comment 3

18 years ago
add keyword nsbeta2; cc beppe
Keywords: nsbeta2

Comment 4

18 years ago
Putting on [nsbeta2-] radar. Not critical to beta2.  Put on relnote keyword.
Keywords: relnote
Whiteboard: [nsbeta2-]

Updated

18 years ago
Status: NEW → ASSIGNED

Comment 5

17 years ago
pushing this one out to future
Target Milestone: M17 → Future

Updated

17 years ago
Keywords: nsbeta2, relnote → helpwanted
Whiteboard: [nsbeta2-]

Comment 6

17 years ago
adding help wanted keyword

Updated

17 years ago
Whiteboard: [d&d]

Updated

16 years ago
Blocks: 85963

Comment 7

16 years ago
spam composer change
Component: Editor: Core → Editor: Composer

Comment 8

16 years ago
removing myself from the cc list

Updated

15 years ago
Component: Editor: Composer → Editor: Core

Comment 9

15 years ago
Chris--I suspect this is related to our embedding customer's issue (616141).  I
think it's a core d&d issue or a core selection issue.  Will probably need some
cycles from mjudge to determine.
Keywords: topembed
Target Milestone: Future → ---

Comment 10

15 years ago
topembed+, at least for investigation
->mjudge
Assignee: brade → mjudge
Status: ASSIGNED → NEW
Keywords: topembed → topembed+

Comment 11

15 years ago
Kin poked around enough to see that part of the problem is the code here needs
to be smarter:
http://lxr.mozilla.org/seamonkey/source/layout/html/base/src/nsFrame.cpp#1312

-->kin for now
Assignee: mjudge → kin
Whiteboard: [d&d] → [d&d]editorbase
(Assignee)

Updated

15 years ago
Status: NEW → ASSIGNED
Target Milestone: --- → mozilla1.4alpha

Updated

15 years ago
Blocks: 193020
editorbase+
Whiteboard: [d&d]editorbase → [d&d]editorbase+
(Assignee)

Comment 13

15 years ago
Created attachment 116557 [details] [diff] [review]
Patch Rev 1

This patch allows us to drag -moz-user-select:all, images and hrs on the mouse
down. The changes that enable this are in nsFrame.cpp. Also included in this
patch is a small change in nsHTMLDataTransfer.cpp that prevents the editor from
dropping content into the middle of -moz-user-select:all subtrees.
(Assignee)

Comment 14

15 years ago
Created attachment 116877 [details] [diff] [review]
Patch Rev 1.1

This patch is almost identical to patch rev 1, except it adds code that checks
to see if the user actually clicked within the bounds of a -moz-user-select:all
subtree. Apparently, in some cases, selection will hilite -moz-user-select:all
subrees even if you haven't clicked in it.
Attachment #116557 - Attachment is obsolete: true
(Assignee)

Updated

15 years ago
Attachment #116877 - Flags: review?(mjudge)
(Assignee)

Comment 15

15 years ago
Created attachment 116878 [details] [diff] [review]
Patch Rev 1.2

Same as previous patch except I moved:

+      rv = aRelativeView->GetParent(aRelativeView);
+      if (NS_FAILED(rv)) return PR_FALSE;

to the bottom of the while loop. Duh ... thanks for catching that mjudge.
Attachment #116877 - Attachment is obsolete: true
(Assignee)

Updated

15 years ago
Attachment #116877 - Flags: review?(mjudge)
(Assignee)

Updated

15 years ago
Attachment #116878 - Flags: review?(mjudge)

Comment 16

15 years ago
Comment on attachment 116878 [details] [diff] [review]
Patch Rev 1.2

looks good now
Attachment #116878 - Flags: review?(mjudge) → review+
(Assignee)

Updated

15 years ago
Attachment #116878 - Flags: superreview?(sfraser)

Updated

15 years ago
Attachment #116878 - Flags: superreview?(sfraser) → superreview+

Updated

15 years ago
Whiteboard: [d&d]editorbase+ → [d&d]editorbase+,edt_x3

Updated

15 years ago
QA Contact: sujay → beppe
(Assignee)

Updated

15 years ago
Target Milestone: mozilla1.4alpha → mozilla1.4beta
(Assignee)

Comment 17

15 years ago
Patch Rev 1.2 checked into the TRUNK:

mozilla/layout/html/base/src/nsFrame.cpp              revision 3.427
mozilla/editor/libeditor/html/nsHTMLDataTransfer.cpp  revision 1.79
Status: ASSIGNED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → FIXED
(Assignee)

Comment 18

15 years ago
*** Bug 194280 has been marked as a duplicate of this bug. ***

Comment 19

15 years ago
using trunk build from 2003040708 on win2K, this works fine. This is what I did:
1. opened new composer window
2. entered several lines of text
3. inserted image in first line of text
4. selected image and moved in several different locations via select & drag
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.