a suggestion for the url bar: remember old titles

RESOLVED WONTFIX

Status

()

Firefox
Address Bar
RESOLVED WONTFIX
10 years ago
5 years ago

People

(Reporter: Seth Spitzer, Unassigned)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
a suggestion for the url bar:  remember old titles

here's something that just happened to me:

I had been to a bugzilla page a while ago and I remember the word "crash" was in the page title.  I quit the browser, and started back up, and upon restart that url got the title "Log in to Bugzilla".

later, I tried searching for "crash" in the url bar, and could not find my page.

I know we have bugs (or code?) to prevent stomping on the title in case of a 3xx, 4xx or 5xx http code, but in this case, I got a 2xx.

perhaps there is a way we could store "old" page titles, and search those as well?  

perhaps this is not common enough to worry about.  the second question is where would we store it?  (as an annotation?  we're not searchings those yet.)
(Reporter)

Comment 1

10 years ago
this is smelling like a wontfix, but I'll let dietrich decide that.

Comment 2

10 years ago
what page was it? process_bug? post_bug? show_bug (for a secure bug)?

in the final case, perhaps the page should have a 403 status...
(Reporter)

Comment 3

10 years ago
> what page was it? 

show_bug.cgi for a non-secure installation of bugzilla
how does the URL bar behave when you get a 302 redirect for a page you already had a title stored for?  Does it still keep it around?

Probably the best thing to do in Bugzilla would be to 302 redirect to a login page with a return path to the page to go to after logging in, so that way the title of the login page doesn't become associated with the bug URL.  A successful login would then 302 redirect (or probably javascript refresh onload to avoid redirecting a POST - link to click on the page to go back for those without js) back to the page you attempted to access before getting the prompt.  This would also eliminate the POST from the login form screwing up your URL as well.

Updated

9 years ago
Duplicate of this bug: 439084
this sounds like trying to optimize for an edge case, we should surely try to be clever with title changes, but always keeping an old title may not be a good way to do that (also for the perf impact it has).
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.