If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

cannot scroll bookmarks toolbar folder with touchpad on macbook pro (10.5)

RESOLVED WORKSFORME

Status

()

Core
Event Handling
RESOLVED WORKSFORME
10 years ago
9 years ago

People

(Reporter: Mitchell Lewandowski, Unassigned)

Tracking

unspecified
PowerPC
Mac OS X
Points:
---
Bug Flags:
blocking1.9 -

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9b4pre) Gecko/2008030104 Minefield/3.0b4pre
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9b4pre) Gecko/2008030104 Minefield/3.0b4pre

I have several bookmark folders within a main folder that resides on my bookmark bar.  When I click the main folder (revealing a subfolder list longer than the height of my resolution), I cannot scroll the list of my subfolders when using the touchpad on my Macbook Pro.  If I attach a mouse however, I can scroll the list just fine.  My apologies is this is a dup, but I couldn't see anything similar in the bugs list.

Reproducible: Always

Steps to Reproduce:
1. Create/import a folder on the bookmark bar that has many subfolders
2. Click the created/imported folder
3. Attempt to scroll the list with the touchpad
Actual Results:  
The list of subfolders does not scroll

Expected Results:  
The list of subfolders should scroll

Not sure the theme matters, I believe I've tried it with the default theme as well, but I'm using Aronnax's Gran Paradiso Outlook 0.9.9.3.
(Reporter)

Comment 1

10 years ago
I double checked, the scrolling doesn't work with the default theme either.
Component: Bookmarks → Places
QA Contact: bookmarks → places

Comment 2

10 years ago
I'd bet this requires a call to hardware at the Mac OS X level. Scrolling pages DOES work with the trackpad on a MacBook (late 2007), though.
(Reporter)

Comment 3

10 years ago
Yep, it scrolls webpages just fine, just not folders.  I believe this also affects the Mighty Mouse too (at least it affects mine).

Comment 4

10 years ago
I've got similar behavior with the main Bookmarks menu on Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9b5pre) Gecko/2008031904 Minefield/3.0b5pre

if i click a non-bookmark-area on the bookmark menu, the menu collapses, and upon reopening the menu i can two-finger-scroll

if i scrub over to the Help menu (not clicking anything), let the Help menu open, and then go back over to the Bookmarks menu, I can two-finger-scroll

This makes me think:
a) two-finger-scroll requires focus
b) the menus somehow dont have focus
   i) clicking part of the menu might change this, though it seems to cure the problem until the next browser restart, which doesnt make sense to me
   ii) the focus going to the text field in the help search would also seem to have something to do with this, though again it seems to cure the problem until the next browser restart

Comment 5

10 years ago
I can confirm the previous comment with Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; nl; rv:1.9b5) Gecko/2008032619 Firefox/3.0b5. (Macbook pro, including all patches) In the Bookmark menu two-finger scroll never works the first time. Close and re-open the Bookmark menu always makes it work for the rest of the browser session.

Updated

10 years ago
Flags: blocking-firefox3?
--> Core::Event Handling
Component: Places → Event Handling
Flags: blocking-firefox3?
Product: Firefox → Core
QA Contact: places → events
Carrying over blocking nomination, though I don't think this should block.
Flags: blocking1.9?

Comment 8

10 years ago
This bug is highly visible to affected users and operates on a central UI component having to do with an area that is one of the main focuses of the next Firefox release. This bug makes long menus nearly unworkable. It's annoying enough that some users will refuse to upgrade and/or go to another browser if this isn't fixed before release.
Given the fact that if you mouse over the up or down arrows, you get a scroll, also, it seems the two finger scrolling does work some times (actually seemed to work for me *most* of the time, but I eventually ended up using the up down arrows, as the two finger scrolling seemed to stop working.  Seems to be related to where your mouse is located when you start two finger scrolling).  

In any case, this doesn't destroy the user's experience, and it's something we could fix in a dot release.

I still think not blocking, but wanted1.9.0.x+.
Flags: wanted1.9.0.x+
Flags: blocking1.9?
Flags: blocking1.9-

Comment 10

10 years ago
I disagree. The scroll arrows are smallish targets, and the scroll-down arrow is far away from the bookmarks entry on the menu bar. This has the potential for a highly frustrating experience. The size of the subset of users for whom this destroys the experience depends largely on personal styles of interacting with the software, which we don't know; however, I'm here to tell you that the subset is non-empty.

Comment 11

10 years ago
May be something to consider when making the decision to solve this for the next release or not; two finger scroll just works in FF2, people are used to it, and now all of a sudden it stopped working in FF3, from the user's point of view this is clearly a regression, and regressions are usually not desirable I think.

Comment 12

10 years ago
Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; nl; rv:1.9) Gecko/2008051202 Firefox/3.0 ID:2008051202

Using this build (RC1), this bug seems to be fixed.

Comment 13

10 years ago
I just tested it and it seems to be working. 

We should be able to close this bug.
Resolving as WFM per comment 12 and comment 13.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Flags: wanted1.9.0.x+
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.