bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

proxy username/password dialog cancel -> crash

VERIFIED WORKSFORME

Status

()

Core
Networking
P3
critical
VERIFIED WORKSFORME
18 years ago
17 years ago

People

(Reporter: Matt Behrens, Assigned: Gagan)

Tracking

({crash})

Trunk
x86
Windows 95
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

18 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Win95; en-US; m16) Gecko/20000604
BuildID:    2000060420

When connecting through a username/password-validating proxy server to http:
//www.mozilla.org/, if I hit Esc on the prompt for Basic authentication, Mozilla
crashes.

Reproducible: Always
Steps to Reproduce:
1. Set proxy settings to a proxy server that requires a username and password.
2. Start Mozilla.
3. Press Esc when presented with the dialog.

Actual Results:  Mozilla crashed in Necko.



Expected Results:  Not crash :-)

Talkback unfortunately will not work through username/password-validating
proxies, so I must, instead of Talkback info, give you the Windows crash
information:

MOZILLA caused an invalid page fault in
module NECKO.DLL at 0157:606197f2.
Registers:
EAX=00000000 CS=0157 EIP=606197f2 EFLGS=00010246
EBX=60cdc398 SS=015f ESP=0068f590 EBP=0068f958
ECX=0068f908 DS=015f ESI=018be280 FS=125f
EDX=00000002 ES=015f EDI=80000000 GS=0000
Bytes at CS:EIP:
66 83 38 00 75 16 83 7d e8 01 74 06 83 7d e8 00
Stack dump:
018be280 60cdc398 00000197 60d03de4 00000016 0000003f 00000001 00000000 00000000
00740068 00700074 002f003a 0077002f 00770077 006d002e 007a006f

Comment 1

18 years ago
Adding crash keyword
Keywords: crash

Comment 2

18 years ago
I don't have a proxy server set up to test this, and I've been unable to find 
any other testers that do either.  confirming so gagan can take a look at 
this ... gagan or tever, are you able to reproduce the reporter's configuration 
(i.e. do you have a proxy server set up at the moment?)
Severity: normal → critical
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: qawanted
(Reporter)

Comment 3

18 years ago
Hmm.  Now I can't reproduce the crash myself, with build 2000062020.  Not quite
sure what's changed.

Comment 4

18 years ago
marking wfm based on reporter's comments
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → WORKSFORME

Comment 5

18 years ago
verified Worksforme
Win95 20000070508
Status: RESOLVED → VERIFIED

Updated

17 years ago
Keywords: qawanted
You need to log in before you can comment on or make changes to this bug.