Primary account email deleted on Thunderbird startup

RESOLVED INCOMPLETE

Status

Thunderbird
General
--
critical
RESOLVED INCOMPLETE
10 years ago
9 years ago

People

(Reporter: Dave Haefner, Unassigned)

Tracking

({dataloss})

x86
Linux
dataloss

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-GB; rv:1.8.1.12) Gecko/20080203 SUSE/2.0.0.12-5.1 Firefox/2.0.0.12
Build Identifier: Downloaded via Yast on OpenSuse 10.3

On starting Thunderbird, the first email was duplicated 3 times, only the first one was readable. The next email following that was readable, but all other emails showed blank (500+ emails in account). Other accounts appeared fine. 

Expecting a corrupt index, I shut down Thunderbird and checked the profile. Both the "Inbox" and "Inbox.msf" files were nearly empty, and only showed the two most recent emails.

I have not deleted any files, I have not compacted the folder, I have not emptied the deleted items, all I did was start it. The previous session appeared to run and close normally, no errors found. 

Since this is on a Linux system with EXT3, the files are probably not going to be recoverable, but I am trying anyways. Since I am attempting the recovery I am not going to restart Thunderbird or copy over the backup until I see what comes back, I may be able to get some of it.

Notes:

Thunderbird is currently handling my email for 10 accounts. At this point only one account (the first one) is affected. Because my email is critical, I do not dare restart Thunderbird until I know the other accounts will not suffer the same problem. I will back up the entire profile and try again for a while, but this is very disconcerting.

Reproducible: Didn't try

Steps to Reproduce:
I have no idea whatsoever what caused the problem to occur. I therefore have no way of reproducing it.


Expected Results:  
Quite frankly this should never have happened.

This is the latest version of Thunderbird 2.0.0.x available through Yast. The system is OpenSuse 10.3, fresh install 2 weeks ago on a Lenovo Thinkpad R61. Lightning Calendar extension installed. Latest Firefox also present and in use on the system.
(Reporter)

Comment 1

10 years ago
Some further information:

As I said Thunderbird handles multiple mail accounts. When I checked the profile I did verify I was looking in the correct account folder.

I noticed a previous bug report regarding something similar happening to the Local Inbox on a Windows machine (310453). This problem occurred on an account Inbox, not local, and on Linux not XP. That bug also seems to be resolved by deleting the index file (which I was expecting to have to do), that will not work in this case.

I will say that I have been using Thunderbird since it came out, both Linux and Windows, and this is the first time I have had a problem like this.

Comment 2

10 years ago
Do you have some antivirus program running? (Not likely on linux I suppose...) Or run out of disk space, or very close to, for that partition?

(Please prefix bug number with "bug", like bug 310453.)
(Reporter)

Comment 3

10 years ago
(In reply to comment #2)
> Do you have some antivirus program running? (Not likely on linux I suppose...)
> Or run out of disk space, or very close to, for that partition?
> 
> (Please prefix bug number with "bug", like bug 310453.)
> 

Antivirus is running at the server, not on this client, so that's not it. 83+GB space left on the drive, no errors reported on a scan last night, so it does not appear to be the drive.

The recovery process on EXT3 file systems is less than stellar, I have a rather large file to chew through. On first pass it looks like large portions of the original index file is there, but very little of the actual emails. This is more related to EXT3, not Thunderbird though.

I copied the backup in this morning and restarted Thunderbird, so far no recurrence. However I did get a warning message about "This folder is being processed, please wait to retrieve messages". I presume this message occurred during the first automatic email retrieval. I have not seen this before, and it has only happened once, just after the backup was restored.

Oh, sorry about the bug prefix.

Comment 4

10 years ago
do you see in latest version started in safe mode?

Comment 5

10 years ago
=> incomplete - reporter appears to be gone.
but please comment if you are still missing data
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Keywords: dataloss
Resolution: --- → INCOMPLETE
(Reporter)

Comment 6

10 years ago
Problem seemed to have disappeared, however today it has happened again. This is on version 2.0.0.17 with a fresh install (no previous accounts imported or copied over). This has been running for about 2 months with no problems, then today all emails prior to the 6th of this month were accesible. They were not recoverable from the data files. Rebuilding the index did not help.

I cannot duplicate the issue, it happens apparantly at random. I tried copying over an older TBird set of data files, and it would not index them or show emails from them. I tried rebuilding the index but it shows a 0byte file an hour after the attempted rebuild.

Something very strange is going on, and I cannot pin it down. I also cannot afford to lose any more emails!
Status: RESOLVED → UNCONFIRMED
Resolution: INCOMPLETE → ---
Version: unspecified → 2.0

Comment 7

10 years ago
This just occurred to my primary email account today. Luckily, I use IMAP, so nothing was actually lost, but it was strange. At first, the folder list was incorrect, so I restarted TBird: No effect, then restarted Windows Vista...when Tbird started back up after Vista restart, the entire email account was gone. The SMTP account was still there, but the email account was completely gone. I added it back and everything worked, but this was definitely weird. I have four computers at work and they all pull off the same IMAP account using TBird. The computer that was afflicted runs Vista, where the others run XP. Not sure if this has anything to do with it, but Vista sucks, so I would not be surprised.
Any ideas on what is causing this to occur?
(In reply to comment #0)
> User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-GB; rv:1.8.1.12)
> Gecko/20080203 SUSE/2.0.0.12-5.1 Firefox/2.0.0.12
> Build Identifier: Downloaded via Yast on OpenSuse 10.3

> Expecting a corrupt index, I shut down Thunderbird and checked the profile.
> Both the "Inbox" and "Inbox.msf" files were nearly empty, and only showed the
> two most recent emails.

It seems an antivirus effects... 

In options-->security-->anti-virus have you uncheched "Allow antivirus clients
to quarantine individual incoming messages" it set on or off?

Ramdomly seems to confirm that is antivirus effect: probably antvirus quarantine all inbox when arrive an email with virus.

But I'm not sure reading on comment here.

Dave you see anithing quarantined?
(Reporter)

Comment 9

9 years ago
It's a bit late to check for that now. Besides, as I stated above, the AV process is server side, not client, and this is on a Linux system not Windows, so AV processes work differently.

Thunderbird has been working now for a few months with no problems, and it is now at version 2.0.0.19. (Great, I probably just jinxed it!)
(In reply to comment #9)
> It's a bit late to check for that now. Besides, as I stated above, the AV
> process is server side, not client, and this is on a Linux system not Windows,
> so AV processes work differently.
Yes, it is: my bugzilla query has returned this non Windows OS... I'm sorry

> Thunderbird has been working now for a few months with no problems, and it is
> now at version 2.0.0.19.
 
Ok, I close this as Incomplete.

Feel free to reopen it, If the issue resurrect.

>(Great, I probably just jinxed it!)
:-D
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago9 years ago
Resolution: --- → INCOMPLETE
You need to log in before you can comment on or make changes to this bug.