"Sort by name" and "Properties" context menu items are disabled on a bookmark folder after dragging item in/out of it [grayed-greyed-out]

RESOLVED FIXED

Status

()

Firefox
Bookmarks & History
--
minor
RESOLVED FIXED
10 years ago
a year ago

People

(Reporter: xtc4uall, Assigned: mak)

Tracking

({regression})

Trunk
regression
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: other infos at comment 11)

(Reporter)

Description

10 years ago
STR:
- creat a test bookmark
- create a new folder
- drag the test bookmark into the new folder
- right click the new folder in bookmarks menu or toolbar

-> 'sort by name' is disabled/greyed out

- repeat the last step (right-clicking)

-> 'sort by name' is usable (again)

above also happens when you dragged the item back out of the folder.

affected: bookmarks menu/toolbar
not affected: bookmarks sidebar, library

maybe a regression of bug 418156, but i don't have the bandwidth for proper regression testing.

perhaps some of our places guys got a clue =)

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b4pre) Gecko/2008030305 Firefox/3.0.0.0 ID:2008030305
(Assignee)

Comment 1

10 years ago
(In reply to comment #0)
> maybe a regression of bug 418156, but i don't have the bandwidth for proper
> regression testing.

doubt it, that code is not involved

Updated

10 years ago
Severity: normal → minor
After closing/reopening Bookmarks Menu - the 'Sort by Name' is restored from the 'grayed' out condition.

Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9b4pre) Gecko/2008030305 Minefield/3.0b4pre Firefox/3.0 ID:2008030305
Regression:
Works: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9b4pre) Gecko/2008022513 Minefield/3.0b4pre ID:2008022513 (13:36)

Busted: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9b4pre) Gecko/2008022514 Minefield/3.0b4pre ID:2008022514 (14:16)

Bonsai: http://bonsai.mozilla.org/cvsquery.cgi?module=PhoenixTinderbox&date=explicit&mindate=1203975360&maxdate=1203977759

Possibly bug 403263
(Reporter)

Updated

10 years ago
Blocks: 403263
Keywords: regression

Updated

10 years ago
Duplicate of this bug: 434835

Updated

10 years ago
Duplicate of this bug: 435516

Comment 6

10 years ago
I'd like to have this fixed in 3.1
(Reporter)

Updated

10 years ago
Flags: wanted1.9.0.x?
Flags: wanted-firefox3.1?
Also "Properties" item is disabled.
Keywords: uiwanted
Summary: 'sort by name' is disabled/greyed-out on folder after dragging item in/out of it → "Sort by name" and "Properties" are disabled/greyed-out on folder after dragging item in/out of it
Is there a workaround for this? Mano, have you had time to look at it?
(Reporter)

Updated

10 years ago
Duplicate of this bug: 449170
(Reporter)

Comment 10

10 years ago
the workaround is mentioned in the STR above:
- repeat the last step (right-clicking) => 'sort by name' is usable (again)
There's an interesting behaviour described in Bug 449170 comment 0:

> Closing and re-opening the Bookmarks menu *before* the right-click on some
> bookmark item does not fix this. You have to right-click a bookmark before
> closing/re-opening the menu will re-enable the Properties command.
> 
Summary: "Sort by name" and "Properties" are disabled/greyed-out on folder after dragging item in/out of it → "Sort by name" and "Properties" context menu items are disabled on a bookmark folder after dragging item in/out of it [grayed-greyed-out]
Whiteboard: other infos at comment 11
(Reporter)

Updated

10 years ago
Duplicate of this bug: 453006
(Reporter)

Comment 13

10 years ago
i don't see this anymore and presume that this got fixed by fixing bug 433542 (like some of the other regressions introduced by fixing bug 403263).
anyone willing to confirm?
(Assignee)

Comment 14

10 years ago
i think all bugs related to context menu items that are grayed out on first right click and working on second right clicks should have been fixed with bug 433542.
and i can confirm it

so fixed by patch in bug 433542
Assignee: nobody → mak77
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Depends on: 433542
Keywords: uiwanted
Resolution: --- → FIXED
Flags: wanted1.9.0.x?

Updated

10 years ago
Flags: wanted-firefox3.1?
Bug 451915 - move Firefox/Places bugs to Firefox/Bookmarks and History. Remove all bugspam from this move by filtering for the string "places-to-b-and-h".

In Thunderbird 3.0b, you do that as follows:
Tools | Message Filters
Make sure the correct account is selected. Click "New"
Conditions: Body   contains   places-to-b-and-h
Change the action to "Delete Message".
Select "Manually Run" from the dropdown at the top.
Click OK.

Select the filter in the list, make sure "Inbox" is selected at the bottom, and click "Run Now". This should delete all the bugspam. You can then delete the filter.

Gerv
Component: Places → Bookmarks & History
QA Contact: places → bookmarks
You need to log in before you can comment on or make changes to this bug.