bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

Feeds/OpenSearch detected on vox.com blogs during pageload but notification vanishes when page is loaded

RESOLVED DUPLICATE of bug 396847

Status

Camino Graveyard
General
RESOLVED DUPLICATE of bug 396847
11 years ago
10 years ago

People

(Reporter: Smokey Ardisson (offline for a while; not following bugs - do not email), Assigned: Chris Lawson (gone))

Tracking

Details

(URL)

STR:

1. Go to a vox.com blog, e.g. http://wevah.vox.c
2. Observe right edge of location bar and the search field during pageload
3. Observe right edge of location bar and the search field when pageload is complete
4. Cry

Viewing source on the loaded page shows the feeds and opensearch description are still there; Firefox doesn't have this problem :(
You aren't listening for pagehide events to clear discoveries on navigation, are you? Fx *did* have the same effect, in bug 407116.

Comment 2

11 years ago
We are looking for STATE_START and STATE_IS_NETWORK in annsIWebProgressListener onStateChange listener. We probably need to do top-level window checking (or check STATE_IS_WINDOW, depending on what the rather vague documentation is trying to indicate about it), but we'll need to do some testing to find out.
I suppose bug 396847 is a dupe of this; I'd forgotten about that one.
(Assignee)

Comment 4

10 years ago
The patch on bug 396847 fixes this.
Hardware: Macintosh → All
Assignee: nobody → cl-bugs-new
Depends on: 396847

Comment 5

10 years ago
It's the same issue then; we don't need one bug per site.
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 396847

Updated

10 years ago
No longer depends on: 396847
You need to log in before you can comment on or make changes to this bug.