Filter with non-ascii name doesn't work

VERIFIED FIXED in M17

Status

MailNews Core
Internationalization
P3
normal
VERIFIED FIXED
18 years ago
10 years ago

People

(Reporter: marina, Assigned: Alec Flett)

Tracking

Trunk
x86
Windows NT

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [nsbeta2+] [6/22] Fix in hand)

Attachments

(2 attachments)

(Reporter)

Description

18 years ago
Filter with non-ascii name doesn't work even though the data entered for the 
filter is us-ascii
Steps to reproduce:
-name filter "fíltér" and set the way that it'll place all incoming messages 
with "subject" in the Subject field to folder named "Folder";
-send message and see what happens:
//message would be placed into your Inbox
(same results with non-ascii data in the Subject field, the only scenario filter 
is working is with ascii filter's name and ascii data in the Subject field
(Assignee)

Comment 1

18 years ago
can you attach the rules.dat that was created?

Comment 2

18 years ago
Reassign to alec.
Assignee: nhotta → alecf
(Reporter)

Comment 3

18 years ago
Created attachment 9908 [details]
screen shot with testing data
(Assignee)

Comment 4

18 years ago
I don't care about screenshots, please attach the rules.dat file that is in the 
server directory for the server you're editing filters for.
Status: NEW → ASSIGNED
(Assignee)

Comment 5

18 years ago
as there is no obvious reason to the user why this would fail and it will appear
like filters themselves just aren't working, I'm nominating this for nsbeta2. I
haven't investigated the root cause of this yet.
Keywords: nsbeta2
Target Milestone: --- → M17
(Reporter)

Comment 6

18 years ago
Created attachment 10059 [details]
a rules.dat file after greating a filter with non-ascii name on IMAP server

Comment 7

18 years ago
nsbeta2+ until 6/22
Whiteboard: [nsbeta2+] [6/22]
(Assignee)

Comment 8

18 years ago
thanks marina
Where is the web page that lists how to do Japanese Input on mozilla? I know I
have the right software installed, but I've forgotten how to actually do it.

Comment 9

18 years ago
I do not know about the page but you should be able to copy/paste text from 
Japanese pages like Netscapce JA (home.netscape.com/ja).
(Assignee)

Comment 10

18 years ago
ok, it looks like the problem is that it thinks the non-ascii filter is not
enabled, even though it is... the enabled="yes" line appears just after the
filter name, so I'm wondering if it's somehow interfering.
(Assignee)

Comment 11

18 years ago
ok, I've got the fix. I really wish I understood why this was happening, but
basically it looks like we were never explicitly enabling the filter! And
somehow, if the filter didn't have 7-bit data, it would enable the filter.
Whiteboard: [nsbeta2+] [6/22] → [nsbeta2+] [6/22] Fix in hand
(Assignee)

Comment 12

18 years ago
fix checked in.
(Assignee)

Comment 13

18 years ago
let's try that again
fix checked in.
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED

Comment 14

18 years ago
marina, please check this out.
QA Contact: momoi → marina
(Reporter)

Comment 15

18 years ago
verifying the fix in 2000-06-29 build, it is working if the filter name contains 
non-ascii chars
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.