Bugzilla 3.0 does not wrap CJK comment text in BugMail

RESOLVED WORKSFORME

Status

()

Bugzilla
Email Notifications
--
major
RESOLVED WORKSFORME
11 years ago
7 years ago

People

(Reporter: himorin, Unassigned)

Tracking

({intl, regression})

unspecified
intl, regression
Bug Flags:
blocking3.2 -

Details

(Reporter)

Description

11 years ago
from bug #388723 comment #38

We should modify bugmail code for wrapping CJK comment test.
We could use perl unicode regexp for checking CJK texts exists or not.
> you can use scripts or block identifier in regexp.
> http://www.unicode.org/Public/UNIDATA/Scripts.txt
> http://www.unicode.org/Public/UNIDATA/Blocks.txt
> like $string =~ /\p{InCJKSymbolsAndPunctuation}/;
Flags: blocking3.2?

Comment 1

11 years ago
The likely complexity of this code means that it's not a 3.2 blocker. Also, nobody's assigned to work on it.
Flags: blocking3.2? → blocking3.2-

Comment 2

8 years ago
Isn't this fixed now that emails are available in HTML format?
(Reporter)

Comment 3

7 years ago
I think the current HTML format is acceptable, excluding one point.
Many of Japanese user does not accept HTML formatted emails (so, in public services they provides an option to select text or html, and also in marketing manual we should avoid to use html formatted email...). For option user can select in the preferences, and also I think we might not need to fix them hard in text formatted since we have many other formatting issues for text formatted emails.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.