Startup with Restore Session: serial 304 error_code 8 request_code 146 minor_code 3

RESOLVED INVALID

Status

()

RESOLVED INVALID
11 years ago
10 years ago

People

(Reporter: pf, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9b3) Gecko/2008020513 Firefox/3.0b3
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9b3) Gecko/2008020513 Firefox/3.0b3

Running 3.0b3 just fine on my main Linux userid.  Tried to start it on a 2nd userid (same machine) and it immediately dies with "serial 304 error_code 8 request_code 146 minor_code 3"


Reproducible: Always

Steps to Reproduce:
1. Start 3.0b3 for first time.
2. Proceed through all steps until it asks for new/restore.
3. Restore... loads a couple of pages and dies. These pages load fine on the other two userids.

Actual Results:  
$ The program 'gecko' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadMatch (invalid parameter attributes)'.
  (Details: serial 152 error_code 8 request_code 146 minor_code 3)
  (Note to programmers: normally, X errors are reported asynchronously;
   that is, you will receive the error a while after causing it.
   To debug your program, run it with the --sync command line
   option to change this behavior. You can then get a meaningful
   backtrace from your debugger if you break on the gdk_x_error() function.)




I believe there is something amiss in that one userid because of past problems with Ff (don't recall specifics); but I've never found anything obvious that could explain why this userid is different with respect to Ff...

I'm mainly looking for a hint where to look for this particular error so that I may do my part to locate its source...

Comment 1

10 years ago
Does this issue also happen with the release versions of Firefox (currently 2.0.0.17 and 3.0.3)? And does this happen with any two userids or just that specific one?
(Reporter)

Comment 2

10 years ago
Turns out this was due to some old libs in /usr/local
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.