want email notification of new versions for tip-compatible addons

RESOLVED DUPLICATE of bug 408574

Status

addons.mozilla.org Graveyard
Developer Pages
RESOLVED DUPLICATE of bug 408574
10 years ago
2 years ago

People

(Reporter: dbaron, Unassigned)

Tracking

Details

As an addon developer who maintains addons on addons.mozilla.org that are compatible with the latest version of the trunk, I'd like to get a notification when new trunk versions are added so that I can update the version compatibility of my addons (after checking that they still work if I haven't been already).  I'd appreciate it if AMO sent me email to say that new versions were added.

I suspect this might help other addon authors who have trunk-compatible addons keep their version compatibility with trunk.  (As a trunk user, it seems like whenever the trunk gets a version bump, addons become incompatible, and it takes a few days for even the highly-trunk-compatible addon authors to update their versions.)  In addition to improving addon compatibility for nightlies, it might also improve compatibility for current betas (e.g., when the beta version is added in AMO only a week or so before we ship the beta).

In other words, when new versions of a product are added in AMO by the admins, I'd like to see automated email (perhaps opt-out in account prefs) go out to any developers of addons that were compatible with what was the latest version before the new versions were added.  (And perhaps also to any developers who bump their compatibility to that old latest-version within a few minutes/hours of the new version being added, to deal with the race condition.)

Steps to reproduce: Admin adds versions "3.0b4" and "3.0b5pre" to Firefox product in AMO.

Expected results: Authors of addons compatible with Firefox "3.0b4pre" get email notification.

Actual results: nothing

Updated

10 years ago
Target Milestone: --- → Future
Version: unspecified → 3.2

Updated

10 years ago
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 408574
(Assignee)

Updated

2 years ago
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.