When delete key pressed the message in message window should move to next message

RESOLVED WORKSFORME

Status

Thunderbird
Mail Window Front End
RESOLVED WORKSFORME
10 years ago
8 years ago

People

(Reporter: Peter Brown, Unassigned)

Tracking

x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.12) Gecko/20080201 Firefox/2.0.0.12
Build Identifier: 2.0.0.12 (20080213)

When delete key pressed the message in message window should move to next message.  As it works now, when first run (see repeatable) Thunderbird doesn't move change the visible window of message.
But, if I exit Tbird and restart and do the same thing, it works: press delete key, the message is deleted from inbox and the message window (not message pane F8) and moves to next message in that folder.

Reproducible: Always

Steps to Reproduce:
1. start TB first time that session, delete a message, won't move to next message
2.Exit TB, restart it, do same thing, it works!
3.



Default theme, no add-ons
WFM here on 

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.1pre) Gecko/20090708 Lightning/1.0pre Shredder/3.0b3pre ID:20090708034418

Reporter you can use last release 2.0.0.22? The issue is still present?
(Reporter)

Comment 2

9 years ago
I have the very ast release 2.0.0.2 and the problem still happens. Open mail message, delete, the message does NOT disappear from window and get replaced by the next (unread) message, unless I restart TB and then the problem goes away.

Happens most frequently, as noted by others, when mail is retrieved first.
Version: unspecified → 2.0
Peter could you try to see if it still happens with
http://ftp.mozilla.org/pub/mozilla.org/thunderbird/nightly/latest-comm-1.9.1/ ?

Comment 4

8 years ago
I have just encountered this same problem.  I read messages in a separate window (not the message pane).  Up until today, when I deleted an open message with either the Delete tool or Edit > Delete Message, the message window would either display the next unread message, or close if the deleted message were the last in the folder list.  Today, I "delete" the currently displayed message and it remains displayed in the open message window, although it does disappear from the list of messages in the folder. T'Bird version 2.0.0.23 (20090812) on Win XP SP2.
Test on 

Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.2.5pre) Gecko/20100507 Lightning/1.0b2pre Lanikai/3.1pre ID:20100507031937

with this options (tools-->options-->advanced, "reading & displayng" tab):
[ ]close message window on delete
[X]open message in : a new message window

TB work as you want.

At this time I can't test this behavior on TB 2.x and the I close this issue as WFM, as it workd in 3.0 and 2.x is a stability and security release
branch. 

Peter, Stuart please try TB 3.x and feel free to reopen it if I'm wrong.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WORKSFORME

Comment 6

8 years ago
I have not encountered this problem in TB 3 (now up to 3.0.4).
You need to log in before you can comment on or make changes to this bug.