Closed Bug 421021 Opened 13 years ago Closed 13 years ago

If selected text contains a URL, but that URL is not a link, then provide a context menu to open the URL

Categories

(Firefox :: Menus, enhancement)

All
macOS
enhancement
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 227922

People

(Reporter: ChrisWooldridge, Unassigned)

Details

Attachments

(1 file)

User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9b3) Gecko/2008020511 Firefox/3.0b3
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9b3) Gecko/2008020511 Firefox/3.0b3

Often in documents, URLs are provided in normal HTML (i.e. not in an <a..> element). A good example of this is bugzilla summaries:

  Firefox crashes in mysite.com


Right now, I tend to select the URI 'mysite.com', right click to get a context menu, copy the text, then open a new tab and paste the URI into the location bar.

A better way would be to have a context menu 'Open as URL in new Tab' is shown when text is selected that looks like it contains a URL.

The definition of 'looks like' might be a simple regex rule that captures:

* The selected text starts with http:..., ftp:, mailto etc
* The selected text contains only characters allowed in a valid URI.
* The selected text ends with .com, .net, .biz, .org. etc 
* Allowance must also be made for country specific domains.



Reproducible: Always

Steps to Reproduce:
1.
2.
3.
Status: UNCONFIRMED → RESOLVED
Closed: 13 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 227922
You need to log in before you can comment on or make changes to this bug.