Report Broken Web Site icon is missing in Help menu

RESOLVED WONTFIX

Status

()

Firefox
Theme
--
enhancement
RESOLVED WONTFIX
10 years ago
9 years ago

People

(Reporter: Andrés Delfino, Unassigned)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 1 obsolete attachment)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9b5pre) Gecko/2008030506 Minefield/3.0b5pre
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9b5pre) Gecko/2008030506 Minefield/3.0b5pre

Home and Report Broken Web Site icons are missing in menus.

See attached screen shot.

Reproducible: Always
(Reporter)

Updated

10 years ago
Severity: normal → trivial
Component: Menus → Theme
Version: unspecified → Trunk
(Reporter)

Comment 1

10 years ago
Created attachment 307475 [details]
Missing Home menu item icon in History menu.
(Reporter)

Comment 2

10 years ago
Created attachment 307477 [details]
Missing Report Broken Web SIte menu item icon in Help menu.
QA Contact: menus → theme
Andres: Was the Reporter icon ever present in the help menu on Linux? On the other platforms I don't see icons in the Help menu at all.
(Reporter)

Comment 4

10 years ago
(In reply to comment #3)
> Andres: Was the Reporter icon ever present in the help menu on Linux? On the
> other platforms I don't see icons in the Help menu at all.
> 

I think every toolbar button that has an icon and a menu item, should use its icon in the menu item. Note that we already have the needed icon for the menu item, which would be the same as the icon used for the small toolbar button rendition.

Native Windows applications don't use menu icons. Note that I consider native Windows applications to those applications _shipped_ with Windows. Office is a native Windows application, but it's interface is far from native.

I can't talk about MacOS X and Windows Vista, can't try them.

Updated

10 years ago
Blocks: 381206
(Reporter)

Comment 5

10 years ago
Morphing, because Home menu item icon got fixed recently by bug 419437.
Summary: Home and Report Broken Web Site icons are missing in menus → Report Broken Web Site icons are missing in menus
I don't really think adding yet another menu icon would improve the UI... But you are kind of right with the "every toolbar button that has an icon and a menu item" approach.
(Reporter)

Comment 7

10 years ago
(In reply to comment #6)
> I don't really think adding yet another menu icon would improve the UI... But
> you are kind of right with the "every toolbar button that has an icon and a
> menu item" approach.
> 

Yeah, that's the main reason I'm suggesting this.
Summary: Report Broken Web Site icons are missing in menus → Report Broken Web Site icon is missing in Help menu
Sometimes applications only give icons to frequently used commands to make them easier to spot.  What is the normal strategy for giving out icons to menu items for gnome?

Comment 9

10 years ago
They give many "stock" elements with application-independent icons and labels. If apps maintainer wants icon, adds it (I think).
(Reporter)

Comment 10

10 years ago
Comment on attachment 307475 [details]
Missing Home menu item icon in History menu.

Fixed by bug 419437.
Attachment #307475 - Attachment is obsolete: true
(Reporter)

Comment 11

10 years ago
Comment on attachment 307475 [details]
Missing Home menu item icon in History menu.

Fixed by bug 419437.

Comment 12

10 years ago
I believe #9 might be correct on this one. Regardless of this, this is probably just as frequently used as the "About Firefox" button (obviously not to us Minefield users who use it multiple times a day).

I vote to confirm and possibly change to an enhancement.

Comment 13

10 years ago
Per comment 12 I am confirming and changing to enhancement, as I agree.
Severity: trivial → enhancement
Status: UNCONFIRMED → NEW
Ever confirmed: true
(In reply to comment #4)
> I think every toolbar button that has an icon and a menu item, should use its
> icon in the menu item. Note that we already have the needed icon for the menu
> item, which would be the same as the icon used for the small toolbar button
> rendition.

The page report toolbar button has been removed.
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.