Moving bookmarks from Bookmarks Menu to Unfiled Bookmarks loses bookmark

RESOLVED WORKSFORME

Status

()

Firefox
Bookmarks & History
--
critical
RESOLVED WORKSFORME
10 years ago
9 years ago

People

(Reporter: Henry Walker, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9b3) Gecko/2008020511 Firefox/3.0b3
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9b3) Gecko/2008020511 Firefox/3.0b3

Bookmarks moved from an existing entry under the Bookmarks Menu (imported from previous version of Firefox) into the Unfiled Bookmarks folder doesn't create bookmarks in Unfiled and deletes the originals.

Reproducible: Always

Steps to Reproduce:
1. Select bookmark in 'Bookmarks Menu' folder (or any subfolder)
2. Select 'Organize' then 'Move...' and choose 'Unfiled Bookmarks'
3. Original bookmarks removed from 'Bookmarks Menu' folder and no new bookmark in 'Unfiled Bookmarks'
Actual Results:  
Bookmark deleted

Expected Results:  
Bookmark moved from original location to 'Unfiled Bookmarks'
*or*
Application refuses to move bookmark
*or*
'Unfiled Bookmarks' is not an option for Move command
Component: Bookmarks → Places
QA Contact: bookmarks → places
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b5pre) Gecko/2008030522 Minefield/3.0b5pre

This works for me. I see the bookmark on the bottom of the Unfiled Bookmarks folder.
(Reporter)

Comment 2

10 years ago
I've just re-tested with the latest nightly and Ria is right - it works OK in Minefield 3.0b5pre.

I'll close this now.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → WORKSFORME
Bug 451915 - move Firefox/Places bugs to Firefox/Bookmarks and History. Remove all bugspam from this move by filtering for the string "places-to-b-and-h".

In Thunderbird 3.0b, you do that as follows:
Tools | Message Filters
Make sure the correct account is selected. Click "New"
Conditions: Body   contains   places-to-b-and-h
Change the action to "Delete Message".
Select "Manually Run" from the dropdown at the top.
Click OK.

Select the filter in the list, make sure "Inbox" is selected at the bottom, and click "Run Now". This should delete all the bugspam. You can then delete the filter.

Gerv
Component: Places → Bookmarks & History
QA Contact: places → bookmarks
You need to log in before you can comment on or make changes to this bug.