Closed Bug 421210 Opened 14 years ago Closed 14 years ago

Selecting history sidebar subfolder entries visit them

Categories

(Firefox :: Bookmarks & History, defect)

x86
Windows XP
defect
Not set
normal

Tracking

()

RESOLVED FIXED

People

(Reporter: Noah, Assigned: mak)

References

Details

(Keywords: regression, Whiteboard: [patch in bug 402558])

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b4pre) Gecko/2008022815 Minefield/3.0b4pre
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b4pre) Gecko/2008022815 Minefield/3.0b4pre

Before, clicking anywhere to the left of the favicon of an history entry up to the tree line graphic, highlighted/selected the entry w/o navigating to it. This was very useful b/c it allowed you to grab an entry w/o navigating to it everytime. Now clicking anywhere on the entry makes it load.

The behavior regressed after 20080226_0233 and begins in 20080226_0310. Bug 419549 was checked in on that build, which caused the new behavior.

Reproducible: Always
Blocks: 419549
Keywords: regression
Version: unspecified → Trunk
Status: UNCONFIRMED → NEW
Ever confirmed: true
Seems to be all history sidebar entries, not just sub-folder entries (the By Last Visited view, for example). Dunno if it's worth changing the summary or not.

My biggest complaint is not being able to do multiple-selection-deletes.

Right clicking an entry and then dismissing the context menu without doing anything seems to leave the entry selected without opening it, FWIW, but that will only select one entry at a time.

Mozilla/5.0 (Windows; U; Windows NT 5.2; en-US; rv:1.9b5pre) Gecko/2008030610 Minefield/3.0b5pre - Build ID: 2008030610
mmh, related to the sidebar behaviour, i've found this Bug 258510 that probably should be wontfixed since it does not make sense in the current impl. Instead we should fix the sidebar so that multiple selection is still possible.
Summary: History sidebar subfolder entries can not be selected w/o causing entry to load anymore → Selecting history sidebar subfolder entries visit them
i'd like to fix this in 402558
Assignee: nobody → mak77
Status: NEW → ASSIGNED
Depends on: 402558
Whiteboard: [patch in bug 402558]
fixed in bug 402558

you can now select in sidebar using the space before the favicon
Status: ASSIGNED → RESOLVED
Closed: 14 years ago
Resolution: --- → FIXED
Bug 451915 - move Firefox/Places bugs to Firefox/Bookmarks and History. Remove all bugspam from this move by filtering for the string "places-to-b-and-h".

In Thunderbird 3.0b, you do that as follows:
Tools | Message Filters
Make sure the correct account is selected. Click "New"
Conditions: Body   contains   places-to-b-and-h
Change the action to "Delete Message".
Select "Manually Run" from the dropdown at the top.
Click OK.

Select the filter in the list, make sure "Inbox" is selected at the bottom, and click "Run Now". This should delete all the bugspam. You can then delete the filter.

Gerv
Component: Places → Bookmarks & History
QA Contact: places → bookmarks
You need to log in before you can comment on or make changes to this bug.