focus rectangle not drawn on first activation of dialog

VERIFIED DUPLICATE of bug 25271

Status

()

Core
XUL
P3
normal
VERIFIED DUPLICATE of bug 25271
18 years ago
18 years ago

People

(Reporter: Marko Macek, Assigned: Peter Trudelle)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
Strange behavior of Open Web Location dialog (and probably others).

Click-to-focus mode:

URL entry field is not focused until the dialog is clicked on or the tab key
pressed. (dialog seems to have focus).

Mouse-focus mode has even stranger behavior:

URL field has focus when dialog is not yet focused. When dialog is focused for
the first time the entryfield loses focus. Everything is normalized after the
first time.
(Assignee)

Comment 1

18 years ago
One defect per bug report please. resolving as dup of 25271.  


*** This bug has been marked as a duplicate of 25271 ***
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE

Comment 2

18 years ago
verified, focus bug.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.