All users were logged out of Bugzilla on October 13th, 2018

[BTN]extra padding in buttons

RESOLVED INVALID

Status

()

P3
normal
RESOLVED INVALID
19 years ago
18 years ago

People

(Reporter: xalkina, Assigned: rods)

Tracking

Trunk
Future
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(5 attachments)

(Reporter)

Description

19 years ago
in the attached page there are four submit buttons. the ones left and right are
rendered without any spacing, the two in the middle are enlarged. I suppose
mozilla tries to fit them to the paragraph text above them, but does not use
spacing in all of them
linux/2000060908
(Reporter)

Comment 1

19 years ago
Created attachment 9922 [details]
testcase

Comment 2

19 years ago
Created attachment 10111 [details]
What I see on 061320

Comment 3

19 years ago
Made an attachment of what it looks like here. Looks OK to me... submitter, can
you confirm if you're seeing this or something different? a screenshot would be
helpful.
(Reporter)

Comment 4

19 years ago
Doesn't look ok to me, though it's rendered better on my box. Your image has
space below the text of the button to the frame of the button.
What I mean is: buttons in the middle get more space to the left & right than
the ones left & right.
Screenshot? Oh, have to find out how to make one on linux!!! I'll give it a try
right now...
(Reporter)

Comment 5

19 years ago
Here you go with a screenshot. This is how it renders on my box. What I think is
not right is that the space I indicate with the lines below the buttons is wider
for the second & third button.
(Reporter)

Comment 6

19 years ago
Created attachment 10114 [details]
results on my machine

Comment 7

19 years ago
setting status to New
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 8

19 years ago
Ah, i see it now. the extra padding seems to be caused by the presence of a
space in the label; making an extremely small testcase.

Comment 9

19 years ago
Created attachment 10173 [details]
world's smallest testcase! film at 11.

Updated

19 years ago
Assignee: clayton → pierre

Comment 10

19 years ago
Pierre, please triage these from Clayton's list.

Comment 11

19 years ago
The problem affects all the buttons, not just the submit buttons. The padding is 
proportional to the button name, not to the number of spaces inside the button, 
and it happens regardless of the font family and font size. See the testcase that 
I'm going to attach.

The explanation doesn't seem to be anywhere in html.css. 
Reassigned to HTML Form Controls.
Assignee: pierre → rods
Component: Layout → HTML Form Controls
QA Contact: petersen → ckritzer
Summary: submit buttons rendered differently → extra padding in buttons

Comment 12

19 years ago
Created attachment 10306 [details]
testcase with different fonts and sizes
(Assignee)

Comment 13

19 years ago
In NavQuirks mode (the default mode) buttons will size to 1.5 times the width of 
their text. In strict/standard mode they will size the width of the text plus 
border and padding. 

So, in NavQuirks, the longer the text the more padding you get.

Is there still a bug here? If so, plus state again what exactly is wrong. 
Marking as "Future" for now.


This bug has been marked "future" because the original netscape engineer working 
on this is over-burdened. If you feel this is an error, that you or another 
known resource will be working on this bug,or if it blocks your work in some way 
-- please attach your concern to the bug for reconsideration. 
Status: NEW → ASSIGNED
Target Milestone: --- → Future

Comment 14

18 years ago
Updating QA contact.
QA Contact: ckritzer → bsharma
(Assignee)

Updated

18 years ago
Summary: extra padding in buttons → [BTN]extra padding in buttons
(Assignee)

Comment 15

18 years ago
I think this is working correctly. marking invalid
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.