Accessing images from another server can cause them to not appear




18 years ago
18 years ago


(Reporter: Mike Baptiste, Assigned: pnunn)


Windows 98

Firefox Tracking Flags

(Not tracked)





18 years ago
I'm using build 2000060820 (though I've seen this on previous builds) with
Windoze 98 SE.

My web site ( is hosted by a commercial webhosting provider.
 Their performance is - to put it mildly - awful.  Until I can move everything
to my own server, I've tried to improve performance by moving all the images to
a local server on my own LAN.  Thus when you load a web page off my site, the
HTML is loaded from (via my webhost provider), but the
images are loaded from which is public IP.  The web server is
behind a NORTEL Networks Instant Internet firewall.

Anyway, when using Mozilla to view pages on my site, I notice the images from my
local server (on the same LAN as my desktop running Mozilla) often will not
load.  I'll get the Alt text instead.  This happens about 80-90% of the time on
the first load of a page.  If I reload the page, the image generally shows up
like it should.

Here is where it gets interesting.  I monitored my server log while this was
happening.  Whenever an image did not show up, the log showed a 404 error!  But
if I clicked the link again to reload the page in the frame, the images
generally loaded with a 200 response.  I say generally because just like the
images generally don't show up the first time, they generally, but not always,
show up the second time.  Same URL, nothing changed.  See below:

First page load: - - [10/Jun/2000:08:06:07 -0400] "GET /cgi-bin/Count.cgi?dd=C|df=
hcs_rbufterm HTTP/1.1" 404 223 "" "Mozilla/5.0 (Windows; U; Win98; en-US;
m16) Gecko/20000608" - - [10/Jun/2000:08:06:07 -0400] "GET /images/rbufterm.jpg HTTP/1.1"
404 225 "" "Mozilla/5.0
(Windows; U; Win98; en-US; m16) Gecko/20000608"

Second Page Load: - - [10/Jun/2000:08:06:10 -0400] "GET /cgi-bin/Count.cgi?dd=C|df=
hcs_rbufterm HTTP/1.1" 200 844 "" "Mozilla/5.0 (Windows; U; Win98; en-US;
m16) Gecko/20000608" - - [10/Jun/2000:08:06:10 -0400] "GET /images/rbufterm.jpg HTTP/1.1"
200 84552 "" "Mozilla/5.0
(Windows; U; Win98; en-US; m16) Gecko/20000608"

Now, before you close this and say - upgrade your server (It is Apache
1.3.9/Linux), this has NEVER happened with Internet Explorer or NS 4.7x  I have
never had this problem with my production browsers.  In fact, my stats show VERY
few 404 errors.  As often as I run into this with Mozilla, my 404 stats would be
off the charts if this was a server problem.

It appears that Mozilla is sending a bogus request of some type, but the logs
make it look like everything is OK.

As for the address, that is my firewall.  All teh above requests
bounce off my firewall, back to my server (for me internally anyway).

So this appears to be something odd with Mozilla as all my other browsers,
configured just like Mozilla, have never had this odd problem.

If you need any mroe info or have any questions, let me know!

Comment 1

18 years ago
Not sure what is going on.  I am not seeing this bug on Win95 mozilla 06/09/00 
build.  I closed mozilla and opened and tried reloadingthe page several times 
never had a problem.  I don't think anything in this area was fixed on the 6/9 
build, but it would be good to get the next latest build to test.

Comment 2

18 years ago
I checked out this site mentioned ( using win 98,
(Build ID 2000060814) , and had no problems with any of the images on this page 
loading and showing up. 

Comment 3

18 years ago
Look at all.js in your 
/bin/defaults/prefs directory, and search for a line that says
pref("network.image.imageBehavior",         0); // 0-Accept, 1 
dontAcceptForeign, 2-dontUse

If it's set to 1, then images from forign servers won't load.
Just something to check.

Comment 4

18 years ago
network.image.imageBehavior is set to 0 (Accept)

The best place to test this is to go to 
 Then click down the list of products.  Each page has a graphical counter and a 
picture.  I usually click down that list and at least one of the two won't show 
on each page - you'll just get the Alt Text instead (Count for the counter and 
another one word description for the product pictures).

I tried to grab a later build but only got 060820.  I'll grab the newer zip on 
Monday and try again.

The part that really confused me about this problem is the 404 logs on the 
server.  And the fact that the request generally succeeded on the next try.

Comment 5

18 years ago
Ok, confirmed with that new URL.
The key logo on the top right showed, but home image and the netscape button did 
not.  Hitting reload did not make the images show.  

Adjusting the URL to the new one.  

QA NOTE: When this bug is fixed/tested the orignal url should also be checked.
Ever confirmed: true

Comment 6

18 years ago
I have the same problem at

Tested with Build ID: 2000061311 on WNT 4.

Lots of images should appear, none do.

Comment 7

18 years ago
No problems with this pages with current linux build from 06-17-2000.

Comment 8

18 years ago
Still broken on WIndoze 98 build 2000061820

Note the products images seem to appear 90% of the time.  However the page
counter gifs rarely do.  If you see 'Count' near the top of the page, the image
failed to load.

Perhaps it has to do with the delay of generating the counter GIFs?  SOmething
changed so that the product images appear more often than they did (though I can
get one to fail to load once in a while)

So this is still broken.

Comment 9

18 years ago
->pnunn for investigation
Assignee: gagan → pnunn


18 years ago


18 years ago
Target Milestone: --- → M17


18 years ago
Keywords: nsbeta3
Target Milestone: M17 → M18

Comment 10

18 years ago
triage team:
original URL looks fine on build 2000081608
Last Resolved: 18 years ago
Resolution: --- → WORKSFORME

Comment 11

18 years ago
I expect this bug still exists.  THe reason the included URL works now is all 
content for comes from the same server now.  Before the HTML 
came from our old ISP and the images came from a server on a different network 
using an IP address.

Sorry about the change, but we finally consolidated all our stuff on a local 
server here (where just the images used to be)

I'd recommend trying the other URL listed to see if the problem still 

I'm changing to URL to that since my URL no longer applies.

Comment 12

18 years ago
Works for me:
Platform: PC
OS: Windows 98
Mozilla Build: 2000101214 M18 Trunk Build

Marking as Verified.
You need to log in before you can comment on or make changes to this bug.