Startup error in Georgian Sunbird 0.8; timezone guessing is broken

VERIFIED FIXED

Status

Mozilla Localizations
ka / Georgian
VERIFIED FIXED
10 years ago
10 years ago

People

(Reporter: ssitter, Assigned: gkw)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

10 years ago
Mozilla/5.0 (Windows; U; Windows NT 5.1; ka; rv:1.8.1.13pre) Gecko/20080305 Sunbird/0.8

Starting Sunbird 0.8 or Lightning 0.8 shows error during the timezone guessing:

შეცდომა: ადგილობრივი საათობრივი ზონის გამოტოვება - 'ამერიკა/ნიუ_იორკი'. TypeError: tz has no properties
საწყისი ფაილი: chrome://calendar/content/calUtils.js სტრიქონი: 660

შეცდომა: ადგილობრივი საათობრივი ზონის გამოტოვება - 'ამერიკა/ჩიკაგო'. TypeError: tz has no properties
საწყისი ფაილი: chrome://calendar/content/calUtils.js სტრიქონი: 660

and so on.

The error happens because the string "likelyTimezone" has been translated:
http://mxr.mozilla.org/l10n-mozilla1.8/source/ka/calendar/chrome/calendar/calendar.properties#240

but must be in English:

http://mxr.mozilla.org/mozilla1.8/source/calendar/locales/en-US/chrome/calendar/calendar.properties#214
# LOCALIZATION NOTE (likelyTimezone):
#   Translators, please put the most likely timezone(s) where the people using
#   your locale will be.  Use the Olson ZoneInfo timezone name *in English*,

Comment 1

10 years ago
Thanks, must be fixed for now
Status: NEW → ASSIGNED
(Reporter)

Comment 2

10 years ago
Please note that we already switched the tinderbox to release preparation mode. This means you will have to submit your changes to SUNBIRD_0_8_BRANCH as well to take effect. http://groups.google.com/group/mozilla.dev.l10n/msg/1d11a4a12be3062d
(Reporter)

Comment 3

10 years ago
Error still exists using Mozilla/5.0 (Windows; U; Windows NT 5.1; ka; rv:1.8.1.13pre) Gecko/2008030521 Sunbird/0.8.

Please see Comment #2.

Comment 4

10 years ago
No idea, Georgian localizations 
Mozilla/5.0 (Windows; U; Windows NT 5.1; ka; rv:1.8.1.13pre) Gecko/20080309 Sunbird/0.8
from
http://ftp.mozilla.org/pub/mozilla.org/calendar/sunbird/nightly/latest-mozilla1.8-l10n/
works fine for me
(Reporter)

Comment 5

10 years ago
Steps To Reproduce:
1. Start with new profile to force timezone guessing to run. 
2. Check Error Console after startup.
(Assignee)

Comment 6

10 years ago
(In reply to comment #3)
> Error still exists using Mozilla/5.0 (Windows; U; Windows NT 5.1; ka;
> rv:1.8.1.13pre) Gecko/2008030521 Sunbird/0.8.

the flood of line 660 errors still occur in Mozilla/5.0 (Macintosh; U; Intel Mac OS X; ka; rv:1.8.1.13pre) Gecko/20080310 Sunbird/0.8
(Assignee)

Comment 7

10 years ago
i found the error in the code, patch coming up.
Assignee: giasher → nth10sd
Status: ASSIGNED → NEW
(Assignee)

Comment 8

10 years ago
Created attachment 308798 [details] [diff] [review]
patch v1

Patch removes whole list of timezones and adds only Asia/Tbilisi. Timezone guessing for Georgia should be its capital, Tbilisi.
Attachment #308798 - Flags: review?(giasher)

Comment 9

10 years ago
(In reply to comment #5)
> Steps To Reproduce:
> 1. Start with new profile to force timezone guessing to run. 
> 2. Check Error Console after startup.

Oh, right, i see - changes submitted to SUNBIRD_0_8_BRANCH

(In reply to comment #7)
> i found the error in the code, patch coming up.

Thanks Garry, i'll try to use Your patch after checking new builds.

Comment 10

10 years ago
Garry, thanks again

Seems there is no need for patch as new build
Mozilla/5.0 (Windows; U; Windows NT 5.1; ka; rv:1.8.1.13pre) Gecko/20080311 Sunbird/0.8 works for now and other timezones preserved also

P.S. may be it is reasonable to remove most of _names_ and leave only 24+ (for some "halh-houred" zones) with adding numbers in parenthesis, like:
Greenwich (0)
Somecity1[, Somecity2, Somecity3] (+1)
Somecity1[, Somecity2, Somecity3] (+2)
Somecity1[, Somecity2, Somecity3] (+3)
Tbilisi[, Somecity2, Somecity3] (+4) (here for Georgian only)
etc.
and let localizers to choose content themselve
(Assignee)

Comment 11

10 years ago
(In reply to comment #9)
> Oh, right, i see - changes submitted to SUNBIRD_0_8_BRANCH

You should submit to the MOZILLA_1_8_BRANCH and the trunk as well.

> Seems there is no need for patch as new build
> Mozilla/5.0 (Windows; U; Windows NT 5.1; ka; rv:1.8.1.13pre) Gecko/20080311
> Sunbird/0.8 works for now and other timezones preserved also

I'll test again later to see if the problem still exists.
(Assignee)

Comment 12

10 years ago
(In reply to comment #11)
> I'll test again later to see if the problem still exists.

გაფრთხილება:  საათობრივი ზონა გუმანით
  /mozilla.org/20071231_1/America/Los_Angeles (UTC-0800/-0700).
როგორც ჩანს, ეს ZoneInfo საათობრივი ზონა ამ წლის საოპერაციო სისტემის საათობრივ ზონას ემთხვევა.
ეს ZoneInfo საათობრივი ზონა შეირჩა საოპერაციო სისტემის საათობრივი ზონის
შესაბამისად, ინგლისურენოვანი ინტერნეტ მომხმარებლების საათობრივი ზონების მსგავსად.

I get no more line 660 errors, that was fixed somewhere else, just the above "blue coloured" timezone detection. Works for Mozilla/5.0 (Macintosh; U; Intel Mac OS X; ka; rv:1.8.1.13pre) Gecko/20080311 Sunbird/0.8

I am of the opinion that the auto-detection should give Asia/Tbilisi instead of America/Los_Angeles, which my patch corrects. Should the patch v1 be taken?

Comment 13

10 years ago
(In reply to comment #11)
...
> You should submit to the MOZILLA_1_8_BRANCH and the trunk as well.

Done ~ 3 days ago(In reply to comment #12)

(In reply to comment #11)
> I am of the opinion that the auto-detection should give Asia/Tbilisi instead of
> America/Los_Angeles, which my patch corrects. Should the patch v1 be taken?

i don't think it is necessary, argument:
On my computer auto-detection gives Asia/Tbilisi.
You can change regional/timezone settings on Your computer and try to reproduce (after deleting profile).
Let's avoid re-adjusting timezone for lot of Georgian language users abroad.
If You have stronger arguments, we can discuss this.
(Assignee)

Comment 14

10 years ago
(In reply to comment #13)
> If You have stronger arguments, we can discuss this.

Nope, absolutely no problems with that, so this bug can be resolved I guess since the Georgian build works fine.
(Reporter)

Comment 15

10 years ago
Verified fixed using Mozilla/5.0 (Windows; U; Windows NT 5.1; ka; rv:1.8.1.13pre) Gecko/2008031122 Sunbird/0.8. Startup error is gone.
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED
(Reporter)

Updated

10 years ago
Status: RESOLVED → VERIFIED
(Assignee)

Updated

10 years ago
Attachment #308798 - Flags: review?(giasher)
You need to log in before you can comment on or make changes to this bug.