Closed Bug 421384 Opened 12 years ago Closed 12 years ago

Startup error in Portuguese Sunbird 0.8; timezone guessing is broken

Categories

(Mozilla Localizations :: pt-PT / Portuguese, defect)

x86
Windows XP
defect
Not set

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: ssitter, Assigned: lloco73)

References

Details

Attachments

(1 file)

Mozilla/5.0 (Windows; U; Windows NT 5.1; pt-PT; rv:1.8.1.13pre) Gecko/20080305 Sunbird/0.8

Starting Sunbird 0.8 or Lightning 0.8 shows error during the timezone guessing:

Erro: Skipping locale timezone 'Europa/Lisboa'. TypeError: tz has no properties
Ficheiro de origem: chrome://calendar/content/calUtils.js Linha: 660

The error happens because the string "likelyTimezone" has been translated:
http://mxr.mozilla.org/l10n-mozilla1.8/source/pt-PT/calendar/chrome/calendar/calendar.properties#240

but must be in English:

http://mxr.mozilla.org/mozilla1.8/source/calendar/locales/en-US/chrome/calendar/calendar.properties#214
# LOCALIZATION NOTE (likelyTimezone):
#   Translators, please put the most likely timezone(s) where the people using
#   your locale will be.  Use the Olson ZoneInfo timezone name *in English*,
Assignee: joao.neves → lloco73
Please note that we already switched the tinderbox to release preparation mode. This means you will have to submit your changes to SUNBIRD_0_8_BRANCH as well to take effect. http://groups.google.com/group/mozilla.dev.l10n/msg/1d11a4a12be3062d
Carlos hasn't responded in the meantime and the issue is simple to solve and critical for calendar to work, so I'll correct it. A patch is attached. That patch is going to be committed next.
Committed to trunk, MOZILLA_1_8_BRANCH, SUNBIRD_0_8_BRANCH. I think that's all.
Status: NEW → RESOLVED
Closed: 12 years ago
Resolution: --- → FIXED
thanks joão i saw the bug but i was out and without net access so thanks again.
Verified fixed using Mozilla/5.0 (Windows; U; Windows NT 5.1; pt-PT; rv:1.8.1.13pre) Gecko/2008030920 Sunbird/0.8.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.