Closed Bug 421392 Opened 13 years ago Closed 13 years ago

(NS_ERROR_FILE_NOT_FOUND) [nsIXPCComponents_Utils.import]

Categories

(Toolkit :: Downloads API, defect)

x86
Windows XP
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 408412

People

(Reporter: johnjbarton, Unassigned)

References

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b4) Gecko/2008030317 Firefox/3.0b4
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b4) Gecko/2008030317 Firefox/3.0b4

In FF3.0b4rc1 I get this error message:
uncaught exception: [Exception... "Component returned failure code: 0x80520012 (NS_ERROR_FILE_NOT_FOUND) [nsIXPCComponents_Utils.import]"  nsresult: "0x80520012 (NS_ERROR_FILE_NOT_FOUND)"  location: "JS frame :: chrome://browser/content/browser.js :: DMP_init :: line 7166"  data: no];

It does not occur on FF2.0.0.12.  

It happens every time I restart FF3.

The stack that comes into JSD's onError  is
<top>
(0)chrome://firebug/content/errors.js:98-233@99
<bottom>

which points to
    // extends ConsoleObserver

    observe: function(object)
    {
HERE>>  if(typeof(FBTrace) == "undefined") return;  /*@explore*/
        var context = FirebugContext;



Reproducible: Always

Steps to Reproduce:
1.
2.
3.
(In reply to comment #0)
> location: "JS frame ::
> chrome://browser/content/browser.js :: DMP_init :: line 7166"  data: no];

Hmm, this is the download manager init stuff, so let's move over to that component. Not sure what would cause the two jsm modules to not exist, though.

> It does not occur on FF2.0.0.12.

The download manager was rewritten for FF3, and this code in particular was added fairly recently.  

> It happens every time I restart FF3.

Do you only see this with Firebug installed?
Blocks: 414461
Component: General → Download Manager
QA Contact: general → download.manager
Version: unspecified → Trunk
See also bug 408412. This sounds like it might be a duplicate of bug 419929 (which is about the addons manager, but it also tries to import DownloadUtils.jsm).
(In reply to comment #1)
> 
> Do you only see this with Firebug installed?
> 
I see it with Firebug + Chromebug, I'm guess the latter is the one that is probing 

Hrm - why would it not exist?
It might exist but have a syntax error (again, see bug 408412).
Blocks: 422767
This went away around FF3b5
Status: NEW → RESOLVED
Closed: 13 years ago
Resolution: --- → WORKSFORME
Duplicate of this bug: 408412
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
Status: REOPENED → RESOLVED
Closed: 13 years ago13 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 408412
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.