Closed Bug 421404 Opened 13 years ago Closed 13 years ago

[FIX]Gmail triggers "ASSERTION: Doing nscoord addition with values > nscoord_MAX"

Categories

(Core :: Layout, defect)

defect
Not set
normal

Tracking

()

RESOLVED FIXED

People

(Reporter: jruderman, Assigned: bzbarsky)

References

()

Details

(Keywords: assertion, testcase)

Attachments

(1 file)

Steps to reproduce:
1. Load https://mail.google.com/mail/ (you must be logged in)

Result:

###!!! ASSERTION: Doing nscoord addition with values > nscoord_MAX: 'a < nscoord_MAX && b < nscoord_MAX', file ../../dist/include/gfx/nsCoord.h, line 150

WARNING: nscoord addition capped to nscoord_MAX: '(PRInt64)a + (PRInt64)b < (PRInt64)nscoord_MAX', file ../../dist/include/gfx/nsCoord.h, line 156
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Mac OS X → All
Hardware: PC → All
Assignee: nobody → bzbarsky
Status: NEW → ASSIGNED
Attachment #307836 - Flags: superreview?(roc)
Attachment #307836 - Flags: review?(dholbert)
Summary: Gmail triggers "ASSERTION: Doing nscoord addition with values > nscoord_MAX" → [FIX]Gmail triggers "ASSERTION: Doing nscoord addition with values > nscoord_MAX"
Keywords: testcase
Comment on attachment 307836 [details] [diff] [review]
Seems to do the trick

Looks good to me, with this exception in the crashtest:

+<div style="width: -moz-fit-content; width: fit-content; clear: both">
(occurs 3 times)

You've got two "width" values on that outer div, and the second one ("fit-content") makes my CSS parser sad.  This is the error I get:
 "CSS Error (file:///home/dholbert/Desktop/foo.html :0.44): Error in parsing value for property 'width'.  Declaration dropped."

I'm guessing you just want the -moz-fit-content value, probably...?

r=dholbert with that fixed (or with an explanation for why it is the way it is)
Attachment #307836 - Flags: review?(dholbert) → review+
That's there so that whenever that part of CSS3 becomes a rec and we rename our implementation to fit-content the test will continue to work.
Ok, cool, I figured it was probably something like that.
Attachment #307836 - Flags: superreview?(roc) → superreview+
Comment on attachment 307836 [details] [diff] [review]
Seems to do the trick

Simple fix to avoid ending up with lengths larger than "infinity" in some cases.  this should be pretty safe.
Attachment #307836 - Flags: approval1.9?
Comment on attachment 307836 [details] [diff] [review]
Seems to do the trick

a1.9=beltzner
Attachment #307836 - Flags: approval1.9? → approval1.9+
Should this bug fix Gmail navigation being completely broken ?
e.g. [Chat] and [Labels] remain collapsed
Unable to navigate to outbox etc.
I filed Bug 421571 for the above mentioned issue, feel free to dupe it if needed
> Should this bug fix Gmail navigation being completely broken ?

Doubt it, since this bug's existence predates the regression range in bug 421571.
Checked in.
Status: ASSIGNED → RESOLVED
Closed: 13 years ago
Flags: in-testsuite+
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.