Expand import options in File>Import to match those in Library import

RESOLVED INVALID

Status

()

Firefox
Bookmarks & History
--
enhancement
RESOLVED INVALID
10 years ago
5 years ago

People

(Reporter: Vesna, Unassigned)

Tracking

Trunk
x86
Windows Vista
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9b5pre) Gecko/2008030607 Minefield/3.0b5pre
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9b5pre) Gecko/2008030607 Minefield/3.0b5pre

File -> Import: add possibility to import bookmarks from file

Reproducible: Always

Steps to Reproduce:
1.
2.
3.
There are options to import from file in Bookmarks -> Show All Bookmarks -> Import and Backup, but maybe there should also be an option in File -> Import, like in Internet Explorer, because people expect it there.
Component: Bookmarks → Places
QA Contact: bookmarks → places
Version: unspecified → Trunk

Comment 2

10 years ago
Sounds like a GREAT idea. However we are too far in to Firefox 3 to add now. We will plan for a future version of Firefox to have this ability.

Thanks for your help in making Firefox the best it can be!!
-Mike
Status: UNCONFIRMED → NEW
Ever confirmed: true

Updated

10 years ago
Severity: normal → enhancement
(Reporter)

Comment 3

10 years ago
(In reply to comment #1)
> There are options to import from file in Bookmarks -> Show All Bookmarks ->
> Import and Backup, but maybe there should also be an option in File -> Import,
> like in Internet Explorer, because people expect it there.
> 
I was expecting this feature there because of title "Import".
If this import allows import from browsers, why not from file?
It's logically. I'm not using IE.
(Reporter)

Comment 4

10 years ago
And it was my first confusing in FF3
when I tried to import my bookmarks from file.
When I didn't find this feature in "File->Import" I thought that it is impossible yet (in beta version). And some my friend said me that this feature exists in "Show All Bookmarks" where I didn't saw because of I hadn't any bookmarks in browser at that moment.
So, it is a question of usability.
(Reporter)

Comment 5

10 years ago
Thank you for your efforts to improve Firefox!

Comment 6

10 years ago
I had the idea of combining the two dialogs and have them call the same thing. So that a dialog will open and ask where to import from you can choose a previous browser like Internet Explorer or Opera then down at the bottom there should be another option with something like "Import bookmarks from file" or "Import profile from file" (and it will read zip files?).

That's my concept on how this might work.

Comment 7

10 years ago
Um, quick question: how is this different from the import option from the Library?  Open the library with Bookmarks > Show all bookmarks then click import.

Comment 8

10 years ago
Oh, I can't read wow.  Ok, I'm relabling this.

Updated

10 years ago
Summary: File -> Import: add possibility to import bookmarks from file → Expand import options in File>Import to match those in Library import
Duplicate of this bug: 424840
Bug 451915 - move Firefox/Places bugs to Firefox/Bookmarks and History. Remove all bugspam from this move by filtering for the string "places-to-b-and-h".

In Thunderbird 3.0b, you do that as follows:
Tools | Message Filters
Make sure the correct account is selected. Click "New"
Conditions: Body   contains   places-to-b-and-h
Change the action to "Delete Message".
Select "Manually Run" from the dropdown at the top.
Click OK.

Select the filter in the list, make sure "Inbox" is selected at the bottom, and click "Run Now". This should delete all the bugspam. You can then delete the filter.

Gerv
Component: Places → Bookmarks & History
QA Contact: places → bookmarks
afaik File/Import has already been moved to Library/Import and Backup menu.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.