Prism creates WebApps folder in user's home folder

RESOLVED FIXED

Status

RESOLVED FIXED
11 years ago
10 years ago

People

(Reporter: marek78uk, Assigned: nossralf)

Tracking

Details

Attachments

(1 attachment)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-GB; rv:1.8.1.12) Gecko/20080208 Fedora/2.0.0.12-1.fc8 Firefox/2.0.0.12
Build Identifier: prism-0.9.en-US.linux-i686.tar.bz2

a new version of prism creates "WebApps" folder within user's home folder. as this folder contains only files used by prism, I guess, it should be a hidden folder. I don't like when applications are creating any visible folder within my home.

Reproducible: Always

Steps to Reproduce:
1. create a new web app link
2. prism creates ~/WebApps folder

Actual Results:  
folder is not hidden


Expected Results:  
folder should be hidden

I think, the best would be to create ~/.prism/WebApps folder so it's easy to guess where prism is storing its files.

Comment 1

11 years ago
I absolutely support that! Creating anything in user personal space without asking first is sooo Microsoft-ish.

Just downloaded and installed 0.9, I can see nice improvements overall, but what WebApps dir is awful. :(
(Assignee)

Updated

11 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 2

11 years ago
Update: it seems there is no way to change location of that unfortunate folder. I've been trying to move it away from ~/, but I couldn't find any kind of prism config file, where I could change path accordingly. Seems like $HOME/WebApps path is hardcoded within prism itself... What a bummer! :(
(Assignee)

Comment 3

11 years ago
(In reply to comment #2)
> Update: it seems there is no way to change location of that unfortunate folder.
> I've been trying to move it away from ~/, but I couldn't find any kind of prism
> config file, where I could change path accordingly. Seems like $HOME/WebApps
> path is hardcoded within prism itself... What a bummer! :(
 
Indeed it is. But I've confirmed the bug, and I agree it should probably go in a hidden folder of some sort. It will stay this way for 0.9 most likely, though.

Comment 4

11 years ago
OK, I'll wait patiently for the next release then..

Comment 5

11 years ago
Yes, we want to get 0.9 out the door exactly so we can get this type of feedback, which is much appreciated.
I'd vote for ~/.webapps since ~/.prism is where the profile data will live for each application and it might get crowded.

Comment 7

11 years ago
Personally, I'd go for any directory, which is not intrusive for user. ~/.webapps seems reasonable suggestion.

Other thing (out of scope of this bug, however) is to create web apps *real* uninstaller, instead of instructing just to remove icon from desktop as a way of 'uninstalling' webapp...
(Assignee)

Comment 8

11 years ago
Created attachment 307995 [details] [diff] [review]
change location of webapp folder

A very simple patch that changes the default webapp location to ~/.webapps

It does no migration if a ~/WebApps directory already exists and is non-empty, which would be unnecessarily complicated (since we have no installer). I think it's OK to just post a note with the next release saying people should move ~/WebApps to ~/.webapps to migrate all webapps on Linux.
Assignee: nobody → nossralf
Status: NEW → ASSIGNED
(Assignee)

Updated

11 years ago
Attachment #307995 - Flags: review?(mark.finkle)
Comment on attachment 307995 [details] [diff] [review]
change location of webapp folder

landed
Attachment #307995 - Flags: review?(mark.finkle) → review+
(Assignee)

Comment 10

11 years ago
Fixed in trunk.
Status: ASSIGNED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → FIXED
Duplicate of this bug: 426068
Duplicate of this bug: 460064
You need to log in before you can comment on or make changes to this bug.