Places Manager folder tree appear reversed in RTL layouts

RESOLVED DUPLICATE of bug 140759

Status

()

Firefox
Bookmarks & History
RESOLVED DUPLICATE of bug 140759
10 years ago
9 years ago

People

(Reporter: tomer, Unassigned)

Tracking

(Blocks: 1 bug, {rtl})

Trunk
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

10 years ago
Created attachment 308039 [details]
Current folders display (wrong for RTL)

I've checked in b5pre, and found that the places manager has folder tree, which is reversed much like other folder trees in the program.

Expected result: 
The tree should be aligned to the right, and the icons should be at the right side of the text.
(Reporter)

Updated

10 years ago
Component: he-IL / Hebrew → Theme
Product: Mozilla Localizations → Firefox
QA Contact: hebrew.he → theme
Version: unspecified → Trunk
(Reporter)

Updated

10 years ago
Blocks: 415606
(Reporter)

Updated

10 years ago
Component: Theme → Places
QA Contact: theme → places

Updated

10 years ago
Blocks: 412273

Comment 1

10 years ago
Dupe of bug 140759?
OS: Linux → All
Hardware: PC → All
(Reporter)

Updated

10 years ago
Depends on: 140759

Updated

10 years ago
Blocks: 415597

Updated

10 years ago
No longer blocks: 412273

Comment 2

10 years ago
Mass-assigning the new rtl keyword to RTL-related (see bug 349193).
Keywords: rtl

Comment 3

10 years ago
Dupe of bug 140759.  Feel free to reopen if this entails more issues.
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED

Comment 4

10 years ago
Oops, stupid keyboard...
Resolution: FIXED → DUPLICATE
Duplicate of bug: 140759

Updated

10 years ago
No longer blocks: 415606

Updated

10 years ago
Blocks: 412273

Updated

9 years ago
No longer blocks: 415597

Updated

9 years ago
Blocks: 285718
Bug 451915 - move Firefox/Places bugs to Firefox/Bookmarks and History. Remove all bugspam from this move by filtering for the string "places-to-b-and-h".

In Thunderbird 3.0b, you do that as follows:
Tools | Message Filters
Make sure the correct account is selected. Click "New"
Conditions: Body   contains   places-to-b-and-h
Change the action to "Delete Message".
Select "Manually Run" from the dropdown at the top.
Click OK.

Select the filter in the list, make sure "Inbox" is selected at the bottom, and click "Run Now". This should delete all the bugspam. You can then delete the filter.

Gerv
Component: Places → Bookmarks & History
QA Contact: places → bookmarks
You need to log in before you can comment on or make changes to this bug.