Unable to convert website to prism app

RESOLVED DUPLICATE of bug 422638

Status

RESOLVED DUPLICATE of bug 422638
11 years ago
10 years ago

People

(Reporter: mfinkle, Assigned: nossralf)

Tracking

Details

From Firefox, navigate to "http://kaai.com.ve/tareanator/" and try to convert to web app (Tools . Convert Website to Application)

Filling in the required data and pressing "OK" does nothing.
Reproduced on Linux. Changing OS to all.
OS: Windows XP → All

Comment 2

11 years ago
Reproduced on Mac OS X on http://goldenline.pl/.

Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.4; en-US; rv:1.9b3) Gecko/2008020511 Firefox/3.0b3
(Assignee)

Comment 3

11 years ago
The website's favicon is actually a PNG file but is described by the <link> tag as image/x-icon (and has a .ico file extension). 

Prism currently trusts either the supplied MIME type or, if that's not supplied, the MIME service (which uses the file extension to determine the MIME type) so both those approaches will fail.

One can check the channel used to download the favicon to get the MIME type. I've experimented with that before, will take a stab at it. Taking.
Status: NEW → ASSIGNED
(Assignee)

Updated

11 years ago
Assignee: nobody → nossralf
Status: ASSIGNED → NEW
(Assignee)

Comment 4

11 years ago
So, the server is sending out HTTP responses with the Content-type set to image/x-icon as well, which makes sense (since Apache uses behavior akin to Mozilla's MIME service, based on file extensions not data sniffing).

Comment 5

11 years ago
I have experienced the same problem with http://www.pandora.com/

There is a relatively simple workaround. Download the favicon to your desktop (in this case http://www.pandora.com/favicon.ico) and then select it as an image instead of the web image.

Updated

10 years ago
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 422638
You need to log in before you can comment on or make changes to this bug.