add correct handling for application/ogg objects

RESOLVED WONTFIX

Status

addons.mozilla.org Graveyard
Plugins
RESOLVED WONTFIX
11 years ago
3 years ago

People

(Reporter: erlehmann, Unassigned)

Tracking

({testcase})

Details

Attachments

(1 attachment)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; de; rv:1.8.1.12) Gecko/20080207 Ubuntu/7.10 (gutsy) Finsterhyäne/2.0.0.12
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; de; rv:1.8.1.12) Gecko/20080207 Ubuntu/7.10 (gutsy) Finsterhyäne/2.0.0.12

According to the MIME type list [1] only application/x-ogg is handled now. RFC 3534 [2] specifies application/ogg for Ogg Stream.

A manual install of the VLC Media Player Mozilla Plugin, the Mplayer Mozilla Plugin etc. is cumbersome.

[1] http://plugindoc.mozdev.org/winmime.html
[2] http://xiph.org/ogg/doc/rfc3534.txt

Reproducible: Always

Steps to Reproduce:
1. Create a (X)HTML site with an <object /> of type "application/ogg"
2. Open it in vanilla Firefox.
3. Nothing happens.
Actual Results:  
Nothing.

Expected Results:  
Prompt for plugin installation, e.g. VLC Media Player Mozilla plugin.

Works on Ubuntu thanks to Ubofox's Apt-enabled plugin finder wizard.

Comment 1

11 years ago
This might be a dup of bug 417467,  "No 'Install Missing Plugins...' message when Flash is included by <object>-Tag only".
(Reporter)

Comment 2

11 years ago
(In reply to comment #1)
> This might be a dup of bug 417467,  "No 'Install Missing Plugins...' message
> when Flash is included by <object>-Tag only".
> 

It isn't. Although FF3 doesn't handle plugins properly, FF2 also doesn't work on application/ogg while it /does/ recognize application/x-ogg. this clearly is a separate issue - IMHO subsequent FF2 releases should recognize application/ogg.

Comment 3

11 years ago
This list of MIME types is specified by each plugin, not by Firefox.  If you go to about:plugins you can see which plugin has claimed support for application/x-ogg and failed to claim support for application/ogg.
(Reporter)

Comment 4

11 years ago
I seem to have failed to explain this properly: This bug occures when *NO* plugin is installed (vanilla Firefox); the plugin finder component is unable to suggest a plugin for application/ogg.

If I install a plugin - be it VLC, Totem, Mplayer etc. - the plugin usually recognizes application/ogg and plays audio or video withut issues.

Comment 5

11 years ago
You get a "missing plugin" message with "application/x-ogg" but not with "application/ogg"?
(Reporter)

Comment 6

11 years ago
Sorry, I relied on third party information which was false. I checked it myself with vanilla FF 2.0.0.12 in safe mode - I get a "missing plugin" message with application/ogg and application/x-ogg but Firefox is unable to suggest a plugin.

The error still is "Firefox plugin finder suggests no plugin for application/ogg".

Disclaimer: I work on a free video CMS in my spare time which makes extensive use of application/ogg.
(Reporter)

Updated

11 years ago
Keywords: polish, useless-UI
(Reporter)

Comment 7

10 years ago
view test case for application/ogg plugin at <http://studikz.org/testcase.xhtml>.

steps:
1. open test case.
2. see no video.
3. PANIC !!1

contrast this experience to ubufox, where it is like:
1. open test case.
2. see no video, but message that plugin can be installed.
3. install plugin.
4. ???
5. PROFIT !!!
Version: unspecified → Trunk
(Reporter)

Comment 8

10 years ago
Created attachment 320439 [details]
Ogg Theora <object> test case

finally found out how to add attachments to bugs. enjoy your test case.
(Reporter)

Updated

10 years ago
Severity: minor → enhancement
(Reporter)

Comment 9

10 years ago
Apparently, Annodex has an Ogg Vorbis + Theora + Speex Plugin extension, but it works only for application/liboggplay <http://annodex.net/software/plugin/index.html>.

The following steps need to be taken now:
1. Modify the extension to work with application/ogg.
2. Update the extension for FF 3 (it still uses install.js)
3. Integrate that stuff into plugin finder.
Confirmed. I uninstalled VLC, restarted the PC, opened a blank Fx3 profile and visited the testcase url. After clicking the "Install Missing Plugin" button, Fx3 founds no plugins.

Anyway I think that this bug:

1) has a Normal, not an Enhancement severity
2) shouldn't have polish and useless-UI Keywords
3) should be moved to addons.mozilla.org - Plugins, because this is not a Fx bug, but simply VLC plugin is not recommended by Mozilla

Can anyone confirm this bug and do the above changes?
Severity: enhancement → normal
Status: UNCONFIRMED → NEW
Component: Plugin Finder Service → Plugins
Ever confirmed: true
Keywords: polish, useless-UI → testcase
Product: Firefox → addons.mozilla.org
QA Contact: plugin.finder → plugin-listings
Version: Trunk → unspecified
(In reply to comment #8)
> Created an attachment (id=320439) [details]
> Ogg Theora <object> test case
> 
> finally found out how to add attachments to bugs. enjoy your test case.

Fx3.5 has ogg support built in.  -> wontfix for older versions
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → WONTFIX
(Assignee)

Updated

3 years ago
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.