Loading JavaScript out of JAR files results in a crash

VERIFIED FIXED

Status

()

Core
Networking
P3
normal
VERIFIED FIXED
18 years ago
17 years ago

People

(Reporter: Taras Tielkes, Assigned: Warren Harris)

Tracking

({crash})

Trunk
x86
Windows NT
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
Sample HTML:
----------------------
<HTML>
<HEAD>
<SCRIPT SRC="jar:http://taras/test.jar!/test.js"></SCRIPT>
</HEAD>
<BODY onload="test();">
</BODY>
</HTML>
----------------------
The test.js file in the test.jar file contains the test function which will 
display a simple alert dialog. Loading this HTML file in a 8 june nightly build 
will result in a crash.

Other details:
-User JDK 1.1.8 JAR tool for archiving.
-no minifest file in JAR archive.
-Tried both hard IPs and server name for loading the jar
(Reporter)

Updated

18 years ago
Keywords: crash

Comment 1

18 years ago
dprice?  warren?  beard?
Assignee: chofmann → beard

Comment 2

18 years ago
Mitch, is this yours?

Comment 3

18 years ago
Handing off to networking.
Assignee: beard → gagan
Component: Tracking → Networking
QA Contact: leger → tever
We don't support the Sun JDK jarsigner yet; sorry. Repackage your jar with zip or 
with Netscape's signtool. 


*** This bug has been marked as a duplicate of 32879 ***
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 5

18 years ago
This bug is about *UNSIGNED* archives.

Navigator 4.x supported the SCRIPT ARCHIVE=... syntax. I've been told that this 
syntax will no longer work in Mozilla, and that I should use the new "jar:.." 
syntax. This bug was filed a long time ago, and I could check again, but at 
least I'd like to know if the syntax described is correct.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---

Comment 6

18 years ago
->warren
Assignee: gagan → warren
Status: REOPENED → NEW
(Assignee)

Comment 7

18 years ago
I don't know what's required here. Back to Gagan.
Assignee: warren → gagan

Comment 8

18 years ago
neither do I. reporter: can you elaborate? Is this still happening? back to you 
warren since the reported problem deals with jar.
Assignee: gagan → warren
(Reporter)

Comment 9

18 years ago
Again: what's the syntax? Is the syntax stated in the bug still valid?
Yes, still valid.
(Reporter)

Comment 11

18 years ago
Ok, I'll check it. Can I use the Java2 JAR tool? (I remember there were some 
problems with the Jdk1.2+ tool back then)
Is this still occurring? What jar tool are you using? Have you tried using "zip"
instead? Zip and jar are the same thing if you're not signing. If this is still
happening, can you give me any information about the crash? When does it crash?
Do you see any assertions? Try running mozilla with -console and look for
assertions.
(Reporter)

Comment 13

18 years ago
Ok, I just checked this with a recent build:
Build ID 2000-10-04-08 WinNT : No crash, everything works as expected.
Fixed as per Taras's comment.
Status: NEW → RESOLVED
Last Resolved: 18 years ago18 years ago
Resolution: --- → FIXED
(Reporter)

Comment 15

17 years ago
Verified.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.