Firefox hangs (blank page) when attempting to load a page after having Firefox open for hours

RESOLVED INCOMPLETE

Status

()

--
major
RESOLVED INCOMPLETE
11 years ago
8 years ago

People

(Reporter: etrash, Unassigned)

Tracking

({hang})

2.0 Branch
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-GB; rv:1.8.1.12) Gecko/20080201 Firefox/2.0.0.12
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-GB; rv:1.8.1.12) Gecko/20080201 Firefox/2.0.0.12

After having Firefox open for a long time it will suddently stop loading pages, just displaying a blank page (sometimes with different background color). I am a heavy tab user which might contribute to the problem. Sometimes I might be able to load another page after closing a few other tabs (which could indicate a memory leak). It never displays any error message though.
After restarting Firefox it works (with the same amount of tabs).
This would match "Hang after prolonged use" http://support.mozilla.com/kb/Firefox+hangs, but the "fix" is also just the workaround of restarting Firefox.
I found others having the same problem (outside the bug tracker). Apologies if I missed the existing bug report.

Reproducible: Sometimes

Steps to Reproduce:
see details
This bug was reported on Firefox 2.x or older, which is no longer supported and will not be receiving any more updates. I strongly suggest that you update to Firefox 3.6.3 or later, update your plugins (flash, adobe, etc.), and retest in a new profile. If you still see the issue with the updated Firefox, please post here. Also, give a stacktrace. Otherwise, please close as RESOLVED > WORKSFORME
http://www.mozilla.com
http://support.mozilla.com/kb/Managing+profiles
http://support.mozilla.com/kb/Safe+mode
https://developer.mozilla.org/En/How_to_get_a_stacktrace_for_a_bug_report
Severity: normal → major
Keywords: hang
Version: unspecified → 2.0 Branch
No reply, INCOMPLETE. Please retest with Firefox 3.6.x or later and a new profile (http://support.mozilla.com/kb/Managing+profiles). If you continue to see this issue with the newest firefox and a new profile, then please comment on this bug.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → INCOMPLETE
You need to log in before you can comment on or make changes to this bug.