list-style-image not relaid-out properly after image loads

VERIFIED DUPLICATE of bug 36703

Status

()

Core
Layout
P3
normal
VERIFIED DUPLICATE of bug 36703
18 years ago
18 years ago

People

(Reporter: mental, Assigned: clayton)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

18 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux 2.2.14 i686; en-US; m16) Gecko/20000602
BuildID:    2000060208

If a page is laid out before a list-style-image image finishes loading, the
resulting layout will be incorrect, as if the image had zero size.  The loaded
images are offset oddly and overlap.

If the page is reloaded, and the image fetched from the cache instead of across
the network, it appears that the image will be availible in time, and the layout
will be correct.

This bug might also be considered a crasher; Mozilla is very likely to crash if
a such a page with a large list is scrolled in its improperly laid-out state.

Reproducible: Always
Steps to Reproduce:
1. clear your cache
2. view the test page on a slow connection (or use a variant with a really big
image)
3. reload the page

Actual Results:  Before the reload, the image takes a little while to load
(expected :P), and the page is laid out before image finishes loading.  The
resulting layout is incorrect, and is not adjusted after the image loads.

After reloading, the image appears instantly from cache, and everything looks
like it should.

Expected Results:  At step 2, the page should have been relaid-out as soon as
part of the list image was displayed (since the size would be known at that point).
(Reporter)

Updated

18 years ago
Summary: list-style-image not relaid-out properly after image finishes loading → list-style-image not relaid-out properly after image loads

Comment 1

18 years ago
perhaps related to bug 36703?
(Reporter)

Comment 2

18 years ago
Hrm, if so, it would appear to be a dup, and fixed, at that.  I'll give the
20000608 build a spin.

Should have tried a wider search before submitting the bug; wasn't thinking of
it as an HTML Element problem.
Could you retest in current build and mark as duplicate of bug 36703 if fixed?

HTML Element is probably the wrong component for the original bug...
I'm going to mark this as a duplicate.  If you still see the problem, please 
reopen the bug I'm marking it a duplicate of (with explanation, of course :-).

*** This bug has been marked as a duplicate of 36703 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE

Comment 5

18 years ago
Verified dupe; this works now that 36703 has been fixed.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.