moving a bookmarks folder using the "organize" button will delete the folder or do nothing

RESOLVED WONTFIX

Status

()

Firefox
Bookmarks & History
RESOLVED WONTFIX
10 years ago
4 months ago

People

(Reporter: Markus, Unassigned)

Tracking

Trunk
PowerPC
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X 10.5; de; rv:1.9b3) Gecko/2008020511 Firefox/3.0b3
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X 10.5; de; rv:1.9b3) Gecko/2008020511 Firefox/3.0b3

Using FF3b3, moving a bookmarks folder from the personal bookmarks toolbar to the top level of the bookmarks menu will delete that folder; moving to a sub-folder of the bookmarks menu worked, though.

Using the nightly build of FF3preb5, the move command does nothing. Drag & drop worked, though.

Reproducible: Always

Steps to Reproduce:
1. Open Places
2. Select a folder from the bookmarks toolbar
3. Select "move" from the "organize" button
4. File that folder to the bookmarks menu folder, top level.
Actual Results:  
The folder is deleted or nothing happens.

Expected Results:  
The folder should be moved.
I was not able to reproduce this with Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b5pre) Gecko/2008030906 Minefield/3.0b5pre
Component: Bookmarks → Places
QA Contact: bookmarks → places
Version: unspecified → Trunk
(Reporter)

Comment 2

10 years ago
I'm using a fresh Firefox profile on a new user account. On startup, I make Firefox import the default Safari bookmarks which yields to folders in the bookmarks toolbar. Then I go to Places, select a folder from the bookmarks menu, select Organize->Move, then select the bookmarks menu in the dialog ... and nothing happens.


I guess anybody should be able to reproduce this bug using Mozilla/5.0 (Macintosh; U; PPC Mac OS X 10.5; en-US; rv:1.9b5pre) Gecko/2008030904 Minefield/3.0b5pre
(Reporter)

Comment 3

10 years ago
Created attachment 308324 [details]
You can see Places after having imported the default bookmarks from Safari.

I only succeeded in moving the "Beliebt" folder from the bookmarks toolbar to bookmarks menu by drag & drop, but not by the organize button.
I tested it for Windows because a lot of bugs are cross-platform. :)
(Reporter)

Comment 5

10 years ago
Only for your information: the bug still exists in the offical FF3b4 and in the latest nightly build: Mozilla/5.0 (Macintosh; U; PPC Mac OS X 10.5; en-US; rv:1.9b5pre) Gecko/2008031104 Minefield/3.0b5pre
(Reporter)

Comment 6

10 years ago
Bug still exists in Mozilla/5.0 (Macintosh; U; PPC Mac OS X 10.5; en-US; rv:1.9b5pre) Gecko/2008032104 Minefield/3.0b5pre

Comment 7

10 years ago
I can confirm part of this bug. Using Fx3rc1 on 10.5.2 (MacIntel) on first launch, no data migration:

1. Open the Library and expand the Bookmarks Menu folder on the left side pane
2. Select the Mozilla Folder
3. Click on the organizer button and select Move
4. Choose the Bookmarks Toolbar as the target
5. Click OK

Expected: the Mozilla Folder should move to the Bookmarks Toolbar

Actual: Nothing seems to happen.

However if you select the Bookmarks Menu in the left pane first, then select the Mozilla Folder on the right pane, you can then use the organizer to Move the folder where ever you want.
Status: UNCONFIRMED → NEW
Ever confirmed: true
is this still visible in 3.1 beta?
(Reporter)

Comment 9

9 years ago
(In reply to comment #8)
> is this still visible in 3.1 beta?

Yes. But (maybe this is by design): if you select an item on the right hand pane in Places, it does work, whereas selecting a folder in the left hand pane and trying to move it using the organize button does simply nothing. As stated before, drag & drop works for the left hand pane, though.


Mozilla/5.0 (Macintosh; U; PPC Mac OS X 10.5; de; rv:1.9.1b2) Gecko/20081201 Firefox/3.1b2

Comment 10

9 years ago
tested on Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1b3pre) Gecko/20090131 Shiretoko/3.1b3pre, just for fun. Everything seems to work. created a folder with bookmarks in the toolbar, using the Places "Organize" menu was able to move the folder to another parent folder.
WFM with Mozilla/5.0 (Macintosh; U; PPC Mac OS X 10.4; en-US; rv:1.9.1b3pre) Gecko/20090202 Shiretoko/3.1b3pre

you can't use "Move" by selecting folders in Tree View. that item is greyed out.  You can successfully Move a folder from View pane to Menu
(Reporter)

Comment 12

9 years ago
Created attachment 360151 [details]
The organize button offers the item "Verschieben" (= move) for folders in the tree view.

(In reply to comment #11)
> WFM with Mozilla/5.0 (Macintosh; U; PPC Mac OS X 10.4; en-US; rv:1.9.1b3pre)
> Gecko/20090202 Shiretoko/3.1b3pre
> 
> you can't use "Move" by selecting folders in Tree View. that item is greyed
> out.  You can successfully Move a folder from View pane to Menu

This is true for 3.1b3pre ... but it was not for (up to) 3.1b2 ... see new attached screenshot.
Bug 451915 - move Firefox/Places bugs to Firefox/Bookmarks and History. Remove all bugspam from this move by filtering for the string "places-to-b-and-h".

In Thunderbird 3.0b, you do that as follows:
Tools | Message Filters
Make sure the correct account is selected. Click "New"
Conditions: Body   contains   places-to-b-and-h
Change the action to "Delete Message".
Select "Manually Run" from the dropdown at the top.
Click OK.

Select the filter in the list, make sure "Inbox" is selected at the bottom, and click "Run Now". This should delete all the bugspam. You can then delete the filter.

Gerv
Component: Places → Bookmarks & History
QA Contact: places → bookmarks
This bug looks like it was due to confusing UI around the move dialog. The dialog has been removed in bug 1432112, so marking this as wontfix.
Status: NEW → RESOLVED
Last Resolved: 4 months ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.