Trying to download a torrent from mininova or isohunt causes an error with download manager

RESOLVED INVALID

Status

()

--
major
RESOLVED INVALID
11 years ago
10 years ago

People

(Reporter: davidcorley, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b5pre) Gecko/2008030904 Minefield/3.0b5pre Creative ZENcast v2.01.01
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b5pre) Gecko/2008030904 Minefield/3.0b5pre Creative ZENcast v2.01.01

When I click on a link to download a torrent from either mininova or isohunt, a window appears with the following:
xxxx.torrent could not be openeed because an unknown error occured. Try saving to disk first and then opening the file.

Reproducible: Always

Steps to Reproduce:
1.Go to mininova.org or isohunt.com
2.Try to download any (legal) .torrent file
3.Error window will appear
Actual Results:  
Error window appears with the following message:
"xxxx.torrent could not be opened because an unknown error occurred. Try saving to disk first and then opening the file."

Expected Results:  
Download should begin and end normally

When I try to do as Firefox suggests and save the file to disk, it tries to save a html page instead of the torrent file. I suspect this is more to do with the sites method of file-serving, but it makes downloading the file impossible.
I have firefox setup to automatically open the downloaded file in uTorrent. If I remove this default setting, and tell firefox to ask me what to do with .torrent files every time I click one the following happens:
1.If I tell firefox to open the file with uTorrent, the error re-appears.
2.If I tell firefox to save the file, it gets saved and the error does not appear.

Comment 1

11 years ago
WFM on:

Mozilla/5.0 (Windows; U; Windows NT 5.2; en-US; rv:1.9b5pre) Gecko/2008030904 Minefield/3.0b5pre ID:2008030904

Are your sure your hard drive isn't full or you have some Firewall problem?
(Reporter)

Comment 2

11 years ago
Problem was not with Firefox, but rather my system not having a default .torrent handler specified correctly.
If you wish to reproduce for whatever reason:
1. Set firefox up to automatically use some application to open .torrent files when they are clicked.
2. Install a seperate application to handle .torrent files.
3. Set it to become the default .torrent handler.
4. Uninstall the newly installed program.
5. Try downloading a torrent file.

Problem can apply to any file type Firefox is told to automatically open with a specified program. To fix the issue, ensure Windows has a program associated with the file type you're trying to automatically open.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → INVALID
(Assignee)

Updated

10 years ago
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.