If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Failure to import TSV file to populate address book with unhelpful error messages; errors in way address book vCards are displayed in GUI

RESOLVED DUPLICATE of bug 432053

Status

Thunderbird
Address Book
RESOLVED DUPLICATE of bug 432053
10 years ago
10 years ago

People

(Reporter: R.P.C. Rodgers, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (X11; U; SunOS sun4u; en-US; rv:1.8.1.9) Gecko/20071127 Firefox/2.0.0.9
Build Identifier: version 2.0.0.6 (20070825)

When trying to import a tab-separated-values file into the address book, the
import failed with a very vague error message.  It should report line numbers
that triggered the problem, and more specific information about *why* the import
failed.  I isolated the lines causing the problem by binary elimination.

The only problmes I could find in the problem lines were unmatched double
quotes, which does not make much sense to me.

1) In the vCard frame in the lower right,
   the "Card for" field is often empty: it should contain a "Last Name,
   First Name" pair, if available, or otherwise a "Display Name", if available,
   or otherwise a "Department", if available, or otherwise an "Organization".
2) The widths of the two column display in the vCard fram vary enormously,
   and in non-sensible ways.
3) Even though "First Name" and "Last Name" fields are defined (and visible in
   an "Edit->Properites" popup), they do not appear in the vCard display or
   in the browsing frame in the upper right.
4) The "Name" field of the browsing frame appears to be populated with the
   first part of an email address, if present.  This is a very peculiar
   choice.  It should contain text drawn from "Last Name",

Note that same problem was observed under Mac SO X 10.5.2 using thunderbird
version 2 beta 1 (20061206).

Reproducible: Always

Steps to Reproduce:

1) Put the TSV list in file ./addresses.tab
2) Start the thunderbird mail client
3) On thunderbird's icon bar at the top, select "Address Book";
a popup appears
4) In the "Address Book" popup, select "Tools->Import...";
an "Import" pop-up appears
5) In response to "Select the type of material to import:"
select "Address Books", then "Next>"
6) Select the "Text file" line that is present in the text box, then "Next>"
7) In the "Select address book file" popup that appears, in the
list "Files of type;" select "Tab Delimited (*.tab, *.txt)", then
in the text window select "addresses.tab" then "Open".
8) In the "Import Address Book" popup, check "First record contains field
names", then follow instructions to match up imported and supported
values. No changes were required as we followed thunderbird's field
structure. Select "OK". 

I would try to cut-and-paste the file with the "bad" addresses here, but doubt
that would work properly.  If you send email to me, I can email the file to
you as an attachment. We are still a couple of weeks away from having a web
site up to make the file available that way.  Pity Bugzilla does not appear to
allow file attachments.
Actual Results:  
An error occurred importing addresses from Text file (LDIF, .tab,
.csv, .txt).
Error importing address book addresses, all addresses may not
have been imported.

Expected Results:  
Line numbers where problem was encountered, ideally with a description of the problem.  Display of number of addresses imported correctly.

There are numerous impediments that sadly prevent thunderbird's address book from being a tool one can really rely upon for managing address information:

1) In the vCard frame in the lower right,
   the "Card for" field is often empty: it should contain a "Last Name,
   First Name" pair, if available, or otherwise a "Display Name", if available,
   or otherwise a "Department", if available, or otherwise an "Organization".
2) The widths of the two column display in the vCard frame vary enormously,
   and in non-sensible ways.
3) Even though "First Name" and "Last Name" fields are defined (and visible in
   an "Edit->Properties" pop-up), they do not appear in the vCard display or
   in the browsing frame in the upper right.
4) The "Name" field of the browsing frame appears to be populated with the
   first part of an email address, if present.  This is a very peculiar
   choice.  It should contain text drawn from "Last Name",
   "Display Name", "First Name", or "Department", in that order.  Organization
   is already a field in this display.
5) Why should the browsing frame contain a "Work Phone" field?  It should
   probably be a simple "Phone" field, displaying the first available from
   Home, Mobile, Work, Pager, and Fax phones, with a one-character descriptor
   pre-pended to it, such as "M:(123)456-7890".
6) The window should report somewhere the number of addresses in the
   address collection that is currently being displayed.
7) There should be a sorting mechanism in the tool to facilitate browsing.

Yes, I realize that perhaps I should have reported this in a second report for
"enhancements"  :)  But I'm exhausted having taken things this far!  Keep up the great work -- I still have high hopes for thunderbird!
(In reply to comment #0)
> Pity Bugzilla does not appear to allow file attachments.

Bugzilla does allow file attachments - come back into the bug in bugzilla and select "Add an attachment" just before the first comment. Without a version of the file/failing example we will find this very hard to debug.

> Yes, I realize that perhaps I should have reported this in a second report for
> "enhancements"  :)  But I'm exhausted having taken things this far!  Keep up
> the great work -- I still have high hopes for thunderbird!

The rest of the items you mention appear to be mainly duplicates of other bugs already filed. We typically limit to one item per bug - otherwise they can get lost. For this bugzilla report, we'll only be dealing with the tab separated file problem.
(In reply to comment #1)
> (In reply to comment #0)
> > Pity Bugzilla does not appear to allow file attachments.
> 
> Bugzilla does allow file attachments - come back into the bug in bugzilla and
> select "Add an attachment" just before the first comment. Without a version of
> the file/failing example we will find this very hard to debug.

Reporter, if you do not provide us with an example of the failing file, then we'll have to close this bug report as incomplete.

As I have already mentioned in comment 1, I think most of your other problems you have on file are duplicates of other bugs.
Whiteboard: CLOSEME 2008-06-02
(Reporter)

Comment 3

10 years ago
Created attachment 319191 [details]
TSV file containing 5 addreses and 1 header, triggers undesireable behavior in t-bird

These 5 addresses were determined by laborious binary division of a TSV file
containing 3474 addresses.  The 5 addresses caused thunderbird to fail to import
the file, without any helpful error messages or line numbers.  Only one of
these lines is one that I suspected might cause problems, with a huge Notes
field.  The others look quite normal to me using vi or "od -c" (though several
had unpaired double-quote characters -- although it's hard to believe
thunderbird would be upset by that!).
(In reply to comment #3)
> Created an attachment (id=319191) [details]
> TSV file containing 5 addreses and 1 header, triggers undesireable behavior in
> t-bird

Thank you for this information.

> Only one of
> these lines is one that I suspected might cause problems, with a huge Notes
> field.  The others look quite normal to me using vi or "od -c" (though several
> had unpaired double-quote characters -- although it's hard to believe
> thunderbird would be upset by that!).

The generally accepted standards for tab/comma separated files is that double-quotes will surround either the separator markers and/or fields containing new lines. Where double-quotes exist on their own, then there should be a pair of them together. This will be the main reason the file is not being accepted by Thunderbird.

The unhelpful error messages should however be fixed, I have raised bug 432053 to cover that, and I will mark this bug as a duplicate of that. I have done this so that we have a "clean" bug that raises only one issue.

I believe that your tab file doesn't match the generally accepted standards, and would potentially be hard to fix in a consistently acceptable manner.

The other issues I have raised are either duplicate of existing bugs (which may have been filed under the core product/MailNews: Address Book component), or in the case of sorting, you can click the headers of the columns display to sort the address book cards as you wish, so that would be works for me.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Whiteboard: CLOSEME 2008-06-02
Duplicate of bug: 432053
(Reporter)

Comment 5

10 years ago
"Generally accepted standards". Where are these published?  I did extensive
web searching before I started this project, to determine just what restrictions
were placed on a TSV file.  The requirements for this file format should be
readily accessible as part of thunderbird documentation, to which any error
messages should point.  I can understand the need to quote the separation character, but that implies there is also a quoting mechanism for quotes.  All
this needs to be made explicitly clear.  I never did find any formal definitions
for TSV file rules.  Thanks for the attention to this problem, and keep up the
great work...
You need to log in before you can comment on or make changes to this bug.