Go Forward/Back Not working from mouse clicks

RESOLVED INCOMPLETE

Status

()

Firefox
Shell Integration
RESOLVED INCOMPLETE
10 years ago
2 months ago

People

(Reporter: John, Unassigned)

Tracking

3.0 Branch
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9b5pre) Gecko/2008031004 Minefield/3.0b5pre
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9b5pre) Gecko/2008031004 Minefield/3.0b5pre

OpenSuSE 10.3 - KDE 3.5 - Since 3b4 but dependent on nightly

Since FF 3b4, mouse clicks on the Go Forward/Back buttons have been sporadically working (has changed back and forth with different nightlies), sometimes not doing anything, but more often clicking the button just duplicates the current tab rather than going forward/back.  This seems related to underlying OS integration with the mouse buttons as, since 3b4, the back and forth hardware mouse buttons don't work at all (save for one 3b5pre nightly).

In the current nightly the toolbar buttons work but not the mouse buttons.

Reproducible: Always

Steps to Reproduce:
1.
2.
3.


Expected Results:  
"Go back one page" or "Go forward one page" when clicking on toolbar button

This occurs with and without Tab Mix Plus (current development) extension installed.

Comment 1

10 years ago
Same here since update to FF3b4. I'm using Gentoo with Gnome 2.20.3.
With FF3b3, the mouse-buttons worked fine, now there is no reaction after clicking on forward/backward buttons.
Installed and enabled addons are Adblock Plus, -Element Hiding Helper, Linkification, NoScript and Save Image in Folder.

Comment 2

10 years ago
Same on:
Ubuntu 7.10 + Gnome 2.20.1
Firefox nightly build: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9pre) Gecko/2008032904 Minefield/3.0pre, without add-ons

Mouse: Logitech MX310

xorg.conf:

Section "InputDevice"
    Identifier  "Mouse1"
    Option      "Buttons"       "6"
    Option      "ZAxisMapping"  "5 6"
    Option      "Resolution"    "800"
    Driver      "evdev"
    Option      "Name"          "Logitech USB-PS/2 Optical Mouse"
EndSection

Comment 3

10 years ago
Same on Mac OS X 10.5.2. If I click on the back or forward button in Firefox 3 beta 5, I get the dropdown history no matter what. The items in the history are selectable; but clicking on the back/forward button does not exhibit the expected behavior (which is to actually go back or go forward one page).

Comment 4

10 years ago
Note that this is NOT Linux-only.

Comment 5

10 years ago
Changing mousewheel.horizscroll.withnokey.action variable into 2 helps a bit. Also, pressing alt+<forward/back button> is useful. However, now the <back button> the "go forward" action and vice versa.

Mozilla/5.0 (X11; U; Linux x86_64; pl; rv:1.9b5) Gecko/2008040818 (Gentoo) Minefield/3.0b5

Mouse: IntelliMouse Explorer 3.0

Section "InputDevice"
...
        Option      "Buttons" "7"
        Option      "ZAxisMapping" "6 7"

Comment 6

10 years ago
Horizontal Scroll works well. However, side buttons on my mx518 logitech which i used to use as back/forward buttons work no more...(was using firefox 2.*) I have no other mice and i am very happy with current mouse. i am using "lomoco" to increase sensitivity of mouse.

Section "InputDevice"
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/input/mice"
    Option         "ZAxisMapping" "4 5"
EndSection

Comment 7

9 years ago
The back and forward buttons only work sporadically when using my Hotmail account. This has been a problem since the previous upgrade, the one before 2.0.0.16

What can I do to correct this?

Tom Thayer

Comment 8

9 years ago
I confirm that back/forward buttoons on mouse was working on some beta of FF3.
It suddendly stopped working (Ubuntu 8.04).
When checking all xorg.conf samples around the web for my Logitech MX700, the "normal" configuraion says 
	Option		"ButtonMapping"		"1 2 3 6 7"
or 
	Option		"ButtonMapping"		"1 2 3 6 7 8 9 10 11"
in addition with
	Option		"Buttons"		"9"
	Option		"ZAxisMapping"		"4 5"

But in this way, if vertical and horizontal scrolling is working as expected in Gnome apps (like gedit where back/forward is horizontal scrolling), Firefox ignore back/forward.

The best I got for Firefox is not ideal (the scroll-up button on the front of the wheel is going back) and is breaking Gnome's horizontal scroll :
		Option		"ButtonMapping"		"1 2 3 8 9 6 7"
So this last one is obviously wrong and only a partial workaround for FF.

The "normal" conf I wrote at first was working with some beta of FF3.
History of this bug : 
 - With FF2, the "normal" conf was working as expected in Gnome, working in FF except for the scroll-up button that was going back
 - With some beta of FF3, I got ecverything working
 - With FF3 final, back/forward are broken.

I found the origin of the bug of the scroll-up going back : xev says that when I RELEASE the scroll-up button, it fire the same event as my back button. Whatever I've configured in xorg.conf
So this bug is minor and there some low-level issue here, but dev must focus effort on back/forward not working as it is a regression !

Updated

7 years ago
Version: unspecified → 3.0 Branch

Comment 9

5 years ago
Not occuring anymore in my distro (Ubuntu). Anyway, I would have reported to launchpad.

Comment 10

3 months ago
John, does this still reproduce for you?
Flags: needinfo?(BlueRubicon+BugZilla)
Whiteboard: [closeme 2017-08-15]

Updated

2 months ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 months ago
Flags: needinfo?(BlueRubicon+BugZilla)
Resolution: --- → INCOMPLETE
Whiteboard: [closeme 2017-08-15]
You need to log in before you can comment on or make changes to this bug.