All users were logged out of Bugzilla on October 13th, 2018

Status

VERIFIED DUPLICATE of bug 288047
11 years ago
11 years ago

People

(Reporter: n.dionne, Unassigned)

Tracking

Details

(Whiteboard: DUPME, URL)

Attachments

(1 attachment)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en; rv:1.8.1.12) Gecko/20080206 Camino/1.5.5
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en; rv:1.8.1.12) Gecko/20080206 Camino/1.5.5

When I need to make corrections in a  tex area , like this one for instance  , the cursorposition is out of aligment with the actual text making adjustment difficult.    For instance, if I want to delte a letter I must position the cursor one or two caharacters to the right of the target before hitting the delete key  n

Reproducible: Always

Steps to Reproduce:
1.Write text in area and try to change it after.
2.
3.
Actual Results:  
Had a hard time making corrections in the sentences

Expected Results:  
Normal text editing

Happens in all forms like this one on all websites

Comment 1

11 years ago
Make sure you aren't viewing Windows Media content in another tab with the Flip4Mac plugin, which is the usual cause of this sort of thing.

If you can reproduce this problem in a form with the form as the ONLY tab and ONLY window open in Camino, please let us know.

cl
(Reporter)

Comment 2

11 years ago
Created attachment 308505 [details]
Screenshot of buggy text editing.

Yes I can reproduce it everytime with just one window and one tab on any webpage that offers this "fill form" feature.
Here is a screenshot of a web page with buggy text editing in the "Details" area.
Notice the cursor position of top of the "n"  Oops! the cursor does not appear in the screenshot.
Anyway, the cursor sits on top the character instead of to the right.
Also notice glyphs to the right of the line, this is after a backspace action over the word "warp" leaving traces of the characters used to write the word.

G5 dual PPC
OS X 10.5.2
Camino 1.5.5

Regards

Comment 3

11 years ago
This isn't the F4M bug, this is a dup of another bug (which I can't find right now) about the cursor becoming progressively more offset horizontally when using certain fonts.
Whiteboard: DUPME

Comment 4

11 years ago
Yeah, I remember that one too, but I can't find it at the moment either...aha, there it is. This is almost certainly bug 288047, which I guess we can add a [10.5] tag to now :-\
Normand, out of curiosity, what is your default monospace font in Camino?  (Your screenshot shows a san-serif font in fields that are set by the server to be monospace.)

I'd agree this is bug 288047....
(Reporter)

Comment 6

11 years ago
The monospace font I was using when I reported the bug was Geeza Pro.
I have switched to Verdana when it was hinted that the issue might be font related. The text editing now behaves normally.
Thanks
(Reporter)

Comment 7

11 years ago
I went to the Font Book app and had a look at Geeza Pro, it changes the alphabet into something that looks like it might be from India or the Middle East.
In the other apps where I use it , Geeza Pro behaves normally and is identical to Lucida Grande.

Updated

11 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 288047

Updated

11 years ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.