FF should offer option to autoexpand bookmarks toolbar vertically when overpopulated

RESOLVED WONTFIX

Status

()

Firefox
Bookmarks & History
--
enhancement
RESOLVED WONTFIX
10 years ago
5 years ago

People

(Reporter: Abe Klag, Unassigned)

Tracking

({uiwanted})

Trunk
uiwanted
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9b4) Gecko/2008030714 Firefox/3.0b4
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9b4) Gecko/2008030714 Firefox/3.0b4

This is an enhancement request.

Current behavior of the bookmark toolbar when it is overpopulated is to place an arrow at the right end of toolbar so user can access additional bookmarks.

Firefox should offer users an option in Tools|Options|Tabs to either keep the current behavior, or to autoexpand the toolbar vertically to accommodate additional bookmarks.

Reproducible: Always

Steps to Reproduce:
1.Size Firefox Windows to approx 3/4 of screen size.
1.Add bookmarks to the bookmark toolbar until full.
2.Add yet another bookmark to the toolbar.

Actual Results:  
Right hand arrow appears in toolbar. If you then maximize the FF window, the arrow is replaced with the bookmark that couldn't fit before.

Expected Results:  
If my suggestion is implemented, the default behavior would remain the same. If the user chooses to enable the option (described in Detals section)to autosize the toolbar, then the arrow will never appear, and the toolbar will vertically autosize to accomodate all bookmarks base on thr Firefox window size.

Updated

10 years ago
Component: Bookmarks → Places
QA Contact: bookmarks → places
Version: unspecified → Trunk

Updated

10 years ago
Whiteboard: DUPEME
(Reporter)

Updated

10 years ago
Summary: FF should offer option to autoexpand bookmarks toolbar should vertically when overpopulated → FF should offer option to autoexpand bookmarks toolbar vertically when overpopulated
It's a good idea. Anyway I think it's better the option has an integer value, which is the max number of bookmark toolbar lines (default:1)

Comment 2

9 years ago
It's a good idea, I would like to see it implemented.

Comment 3

9 years ago
Using  > Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.1b3pre) Gecko/20090112 Shiretoko/3.1b3pre ID:20090112034247 on Windows 7 (6956)
-----------------------
I think it's fixed. When the bookmark is added to the already full list with window size 3/4 of screen size and then window is maximized it always displays the arrows.
sounds good for an extension
Keywords: uiwanted
Whiteboard: DUPEME
Bug 451915 - move Firefox/Places bugs to Firefox/Bookmarks and History. Remove all bugspam from this move by filtering for the string "places-to-b-and-h".

In Thunderbird 3.0b, you do that as follows:
Tools | Message Filters
Make sure the correct account is selected. Click "New"
Conditions: Body   contains   places-to-b-and-h
Change the action to "Delete Message".
Select "Manually Run" from the dropdown at the top.
Click OK.

Select the filter in the list, make sure "Inbox" is selected at the bottom, and click "Run Now". This should delete all the bugspam. You can then delete the filter.

Gerv
Component: Places → Bookmarks & History
QA Contact: places → bookmarks
there is no plan to do this in the core product, though add-ons can do whatever they want.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.