Attachments on signed emails cannot be deleted

RESOLVED DUPLICATE of bug 297314

Status

RESOLVED DUPLICATE of bug 297314
11 years ago
11 years ago

People

(Reporter: bugzilla.mail, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (X11; U; SunOS sun4u; en-US; rv:1.8.1.11) Gecko/20080115 Firefox/2.0.0.11
Build Identifier: version 2.0.0.9 (20080116)

Attachments on signed emails cannot be deleted or detached. The options are greyed out on the menu.

Specifically this has been seen with Thawte Personal Freemail certificates (PKCS #1 SHA-1 With RSA Encryption). A user may wish to trim the size of messages in their "Sent" folder - currently if the emails are signed it's not possible to delete the attachments. This applies to emails in any folder including the INBOX (IMAP).


Reproducible: Always

Steps to Reproduce:
Either
  1. Sign a message with an attachment and send it
  2. Find the message in the Sent folder
  3. Select the attachment
Or
  1. Find a message that's signed with attachments
  2. Select the attachment

Actual Results:  
The "Detach ..." and "Delete" options are greyed out in the context menu and in File -> Attachments.

Expected Results:  
The user would expect to be able to delete attachments whether the email is signed or not.

Updated

11 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 297314
You need to log in before you can comment on or make changes to this bug.